Tappety tap tap!

"M" Specific discussion
jontysafe
Member
Member
Posts: 101
Joined: Sat Oct 24, 2009 10:36 am

Tappety tap tap!

Post by jontysafe » Fri Jan 22, 2010 5:13 pm

I have noticed the last couple of times I took the car out a pronounced tappet noise, really since the snow. I was in Poland this week so the car was sat for a couple of days at the airport, on start-up it was terrible, drove home at a sensible rate and took it straight to Lick Dovett in Hungerford. They now have the car and suspect it needs shim work. It`s all on warranty but I`m beginning to feel a little pissed off. Have had the car since Sep and it`s been in and out of the dealers like a fiddlers elbow. It`s had, new cams, Vanos solenoids, 2 lambda sensors, camshaft position sensor, ECU re-program and now i`m told that the front discs are borderline, after 8000mls!!! I have to admit the supplying dealer Cooper Cobham have been fantastic, all the time the car was in I had a new Z4 sdrive on loan and daily updates as to what was happening. There comes a point though that enough is enough. The car is an absolute hoot to drive but it`s my daily driver and used for work so this is becoming untenable. OK>>>> have just had Lick Dovett on the phone and it`s not shims, they`ve done them and it`s still tapping. Any ideas? I`m thinking more like a shell bearing???

mmm-five
Lifer
Lifer
Posts: 11162
Joined: Sun Nov 30, 2008 1:03 pm
Location: South Liverpool
Contact:

Re: Tappety tap tap!

Post by mmm-five » Fri Jan 22, 2010 5:46 pm

Can't help, but my misfire required a new engine (which is still working after 6,000 miles) after 3 days of diagnostics didn't find the cause.
Trigger’s Z4MC
Some bits now over 163,000 miles, some less than 1,000 miles.
Individual Ruby Black, Individual extended champagne leather, plus many options

Image

User avatar
JayD
Member
Member
Posts: 352
Joined: Mon Jul 02, 2007 9:28 am
Location: Chatham, Kent

Re: Tappety tap tap!

Post by JayD » Fri Jan 22, 2010 5:59 pm

This sounds similar to the problem I had with mine a few years ago.

Mine turned out to be premature wear on the bearings and an oil circulation issue. New engine at 9000 miles.

Has been sweet ever since.....
Interlagos Blue Coupe, CSL's on Vredestein Ultrac Sessanta's and Strut Brace - Gone but not forgotten.......

ROSSI
Newbie
Newbie
Posts: 19
Joined: Thu Nov 19, 2009 8:00 pm
Location: West Cumbria

Re: Tappety tap tap!

Post by ROSSI » Fri Jan 22, 2010 9:30 pm

New discs after 8k?, sounds like some serious driving - has it been tracked?

Has the service book got all the stamps, most importantly the 1200 mile one?

If they can't come up with a fault diagnosis, I think you might be looking @ a new engine (still under warranty so get it sorted for free)

I hope you get it sorted.

i have just had Inspection 1 done @ a cost of £782, which is still hurting. Keep the post going as I'm sure everyone will want to know the outcome.

Good luck!
2007 - ///M COUPE - RUBY BLACK - IMOLA LEATHER - 19'' BLACK CHROME CSL'S

jontysafe
Member
Member
Posts: 101
Joined: Sat Oct 24, 2009 10:36 am

Re: Tappety tap tap!

Post by jontysafe » Sat Jan 23, 2010 10:16 am

Let me clarify a little:- I bought the car at 24,000 its now done about 32,000, I`ve only put 8000 on it. I`m thinking the brake discs were only just within tolerances when I bought it. It started its life as a BMW management car then moved on to its first owner, it has a full BMW service history with the running in service done at the Yorkshire distribution centre hence the YF prefix on reg plate. I think I`m going to push for a replacement engine and discs all round.

Failing that what does everyone think my chances would be to get BMW to take it back under the sale of goods act? I`m thinking probably not after 8000 miles and 4 months. To be honest I don`t want to go down this route as it is actually in cracking condition and if they sort the issues above would be a real keeper, until a decent M6 convertible hoons into price range!!

mmm-five
Lifer
Lifer
Posts: 11162
Joined: Sun Nov 30, 2008 1:03 pm
Location: South Liverpool
Contact:

Re: Tappety tap tap!

Post by mmm-five » Sat Jan 23, 2010 11:18 am

I can't see them doing anything about the brakes, as 32,000 miles on a set is not bad - and the dealer's definition of 'borderline' could mean that it will still have another 5,000 miles left on them :P

To put it into perspective, I bought mine with about 9,000 on the clock and have put 20,000 on it in 13/14 months - and I got the same 'warning' when I went for my inspection at 23,000 miles. I've done two track days (okay they were my first ones in it, so not necessarily the fastest), and have done multiple 200 mile Sunday blasts around Wales and the Peak District. However, I wanted to change the pads to EBC Yellows anyway, so decided to put new discs on at the same time to prevent any bedding in problems.

As for all the other issues, I'm sure you could push for BMW to replace the car or the engine, as if these problems have been ongoing you've got a good case for stating you've given them every chance to rectify it and they haven't.

Unfortunately, they may only offer you back what it's worth now, and not what you paid for it.
Trigger’s Z4MC
Some bits now over 163,000 miles, some less than 1,000 miles.
Individual Ruby Black, Individual extended champagne leather, plus many options

Image

Darren M
Senior Member
Senior Member
Posts: 1028
Joined: Sun Dec 16, 2007 8:14 pm
Location: Devon

Re: Tappety tap tap!

Post by Darren M » Sat Jan 23, 2010 11:55 am

Regarding replacing the car, what would be done New Z4 M's can't be built, and these cars are rare so finding one in the same condition and same spec would be hard.

Jonty, hope you get it all sorted and can enjoy the car. I doubt they'll want to replace the brakes for free. Having said that, as you've had long term issues with the car they just might do that with a little encouragement, especially if it does indeed also need a new engine.
Last edited by Darren M on Sat Jan 23, 2010 5:13 pm, edited 1 time in total.
Current 2011 X1 2.0d xDrive
2006 Z4 M Coupe Interlagos with Light Sepang interior - GONE 08/2012 - PY56 GH* - where now?
2006 Z4 Si Coupe - Montego blue - GONE approx 05/2009 - WJ56 YU* - where now?

User avatar
JayD
Member
Member
Posts: 352
Joined: Mon Jul 02, 2007 9:28 am
Location: Chatham, Kent

Re: Tappety tap tap!

Post by JayD » Sat Jan 23, 2010 4:00 pm

They stripped my engine down first and had to send pics to BMW before they would agree to a new engine. I would certainly insist that they do further investigative work and say you dont want it back until the problem is sorted whether that means a new engine or not.

Good luck with it, I hope you get it sorted either way.
Interlagos Blue Coupe, CSL's on Vredestein Ultrac Sessanta's and Strut Brace - Gone but not forgotten.......

User avatar
Gids
Member
Member
Posts: 190
Joined: Mon Sep 10, 2007 9:29 pm
Location: Solihull, West Mids

Re: Tappety tap tap!

Post by Gids » Sun Jan 24, 2010 6:58 pm

mmm-five how much did you pay for discs and did you do front and rear or just front?
Image
Ruby Black Z4MC

mmm-five
Lifer
Lifer
Posts: 11162
Joined: Sun Nov 30, 2008 1:03 pm
Location: South Liverpool
Contact:

Re: Tappety tap tap!

Post by mmm-five » Sun Jan 24, 2010 7:20 pm

Gids wrote:mmm-five how much did you pay for discs and did you do front and rear or just front?
I got the whole lot done and it cost me about £600 including labour - although I got my EBC Yellows at a special price.

Fronts were about £160 each, rears about £100 each.
Trigger’s Z4MC
Some bits now over 163,000 miles, some less than 1,000 miles.
Individual Ruby Black, Individual extended champagne leather, plus many options

Image

User avatar
Gids
Member
Member
Posts: 190
Joined: Mon Sep 10, 2007 9:29 pm
Location: Solihull, West Mids

Re: Tappety tap tap!

Post by Gids » Sun Jan 24, 2010 7:40 pm

Cheers, not too bad I suppose. I think I may have a warped disc as I'm getting a lot of vibration under braking, going to get the dealer to take a look but always good to know a ballpark figure before hand ;)
Image
Ruby Black Z4MC

alexman
Member
Member
Posts: 272
Joined: Mon Mar 09, 2009 2:06 pm

Re: Tappety tap tap!

Post by alexman » Tue Jan 26, 2010 2:50 pm

I used to get this around 12-13k but haven't noticed it in a long time (now on 19k) - maybe its an oil level or run-in thing?
Z4M Roadster, Red Leather Seats, Fully Loaded

User avatar
mikedav
Senior Member
Senior Member
Posts: 1448
Joined: Mon Sep 24, 2007 5:02 pm
Location: London

Re: Tappety tap tap!

Post by mikedav » Tue Jan 26, 2010 3:57 pm

jontysafe wrote:now i`m told that the front discs are borderline, after 8000mls!!!
In my experience,it's a stunt BMW dealers pull to get more work. They said the same about my sister Mini years ago when it had about 20k on it, and my M3 at 38k.

Neither were true (M3 did need pads though).
mmm-five wrote:I can't see them doing anything about the brakes, as 32,000 miles on a set is not bad - and the dealer's definition of 'borderline' could mean that it will still have another 5,000 miles left on them :P
Mines on original discs and pads at 32k....I've done two track days and the 'Ring on them, too. I'd be miffed if I needed new discs before 40k?

User avatar
JayD
Member
Member
Posts: 352
Joined: Mon Jul 02, 2007 9:28 am
Location: Chatham, Kent

Re: Tappety tap tap!

Post by JayD » Tue Jan 26, 2010 3:59 pm

Likewise, on original discs and pads at 33K. I think front pads will need replacing shortly but discs look ok to me.
Interlagos Blue Coupe, CSL's on Vredestein Ultrac Sessanta's and Strut Brace - Gone but not forgotten.......

jontysafe
Member
Member
Posts: 101
Joined: Sat Oct 24, 2009 10:36 am

Re: Tappety tap tap!

Post by jontysafe » Sat Jan 30, 2010 3:42 pm

Bit of an update: Car still with dealer, no bloody courtesy car from them so will be on to BMW customer services Monday morning. Has had the shims done with no luck and they are still investigating. Before I bought it, it had some warranty work, new camshafts, then when I bought it the engine management light flicked on, new VANOS actuator units, camshaft position sensor and ECU parameters were reset. Lick Dovett has been on to the dealer that replaced the camshafts to ask why, seems that (and I can`t understand why this would effect camshafts) there was excessive cylinder wear on cylinder one? Now it seems there is excessive play on 2 and 3 which points to me of main shell bearing wear or even worse an out of true crank. I`m going to be pushing very hard for either a complete refund (sale of goods act) (doubtful) or a new engine and new discs.

Has anyone got any pointers on how to deal with BMW Customer Services?

Post Reply