Not joined yet? Register for free and enjoy features such as alerts, private messaging and viewing latest posts and topics.

Connected Drive Issue (Z4 E89 2015)

Post Reply
NDP
Newbie
Newbie
Posts: 3
Joined: Thu Nov 03, 2016 1:56 pm
Location: Yorkshire

Connected Drive Issue (Z4 E89 2015)

Post by NDP » Thu Nov 30, 2023 4:02 pm

Can anyone offer a solution to the issue I am having with messages to my Connected Drive. When I send destination messages from my BMW App to my car the software says the message has been sent but when I call up messages in my car in order to start navigation the message has stopped appearing. This has been going on for a few months. I have tried uninstalling and reinstalling the App on my phone but that hasn't worked. I have even tried sending the system a message while sat in the car (both with the engine off and on), nothing seems to work. BMW have ignored messages from me, in their usual helpful way (particularly when the issue is software related).

Any ideas folks?

What I would really like is for someone to tell me where I could also get the embedded 2g sim card updated to a 4g one because yet again BMW will not provide a retro fit.

Cheers,

Neil.

User avatar
Nictrix
Lifer
Lifer
Posts: 5398
Joined: Mon Aug 18, 2014 9:59 pm
Location: Paisley

Connected Drive Issue (Z4 E89 2015)

Post by Nictrix » Fri Dec 01, 2023 9:09 am

Is the yearly subscription needed for this service and have you subscribed.
E89 2014 35i M Sport Black with Black leather :)

AnubisZed
Senior Member
Senior Member
Posts: 1729
Joined: Thu Aug 16, 2012 2:24 pm
Location: Lincolnshire, UK

Connected Drive Issue (Z4 E89 2015)

Post by AnubisZed » Fri Dec 01, 2023 10:07 am

NDP wrote: Thu Nov 30, 2023 4:02 pm .....
What I would really like is for someone to tell me where I could also get the embedded 2g sim card updated to a 4g one because yet again BMW will not provide a retro fit.

Cheers,

Neil.
OK, so from research I've done before it turns out that there isn't a definitive answer. From some of the US based sites you need to upgrade (replace) the combox to the 4G version, but as this is a US specific version I won't confuse the issue with that part number. So looking on the Euro based parts sites the latest combox part number is 84 10 9 257 161, but this went into production in March 2011, which was before the 4G versions came out. There is no superseded version after this time. This is the version I currently have.
Now I've found used ones dated up to 2015 but they all state the software version as being 003.004.031, which is the base software, which was updated some time ago to 003.005.004 (there are some posts on this group mentioning this update, like this one... https://www.z4-forum.com/forum/viewtopic.php?t=144536), but this doesn't update it to 4G.
Now on the US based information there is a part that states that you need to code "+UC4G" to the VO, whether this would make a difference to the Euro combox or not I just don't know and have never tried, mainly as mine is a fully retrofitted system so I don't have some of the specific parts (as they are not required) and definitely not an active subscription to Assist.
Dave
2011, 23i, Grey with Red leather. 8)

My E89 YouTube channel - BMW Z4 Mods
https://www.youtube.com/channel/UCttNBt ... UQnoEvKB2Q

Post Reply