Not joined yet? Register for free and enjoy features such as alerts, private messaging and viewing latest posts and topics.

Anyone Else have an "O" ring problem when changing out their Roof Motor?

Discuss problems you have had or are having with your Z4
Post Reply
User avatar
DashingDaryl
Member
Member
Posts: 65
Joined: Mon Dec 20, 2010 7:21 pm

Anyone Else have an "O" ring problem when changing out their Roof Motor?

Post by DashingDaryl » Mon Sep 18, 2023 11:43 pm

I went to change my roof motor this weekend. When I went to reassemble, I noticed this "O" ring was much too large for the housing it is suppose to sit in.

Knowing it would be impossible to understand what I am talking about via written text, I am including a picture I took off YouTube.

Anyone else have this problem, or did the previous installer just replace it with the wrong size O ring? (Though everything looked original)

Image
Capture.JPG
Capture.JPG (21.78 KiB) Viewed 95 times
Last edited by DashingDaryl on Tue Sep 19, 2023 12:20 am, edited 2 times in total.

User avatar
DashingDaryl
Member
Member
Posts: 65
Joined: Mon Dec 20, 2010 7:21 pm

Anyone Else have an "O" ring problem when changing out their Roof Motor?

Post by DashingDaryl » Mon Sep 18, 2023 11:46 pm

Looking closer at the picture, is the O ring suppose to sit inside a groove?

User avatar
enuff_zed
Lifer
Lifer
Posts: 12464
Joined: Wed Oct 26, 2016 11:05 am
Location: Attleborough, Norfolk

Anyone Else have an "O" ring problem when changing out their Roof Motor?

Post by enuff_zed » Tue Sep 19, 2023 8:26 am

You may find it easier to fit the seal to the top of the spacer and then assemble
Headquarters of 'Norfolk Zed Rescue'.
Vanos seals, Disa mods, EPS motors and column changes, roof motor relocations, suspension refreshes, transport mode resets, anything else you need help with please PM me.

Post Reply