Not joined yet? Register for free and enjoy features such as alerts, private messaging and viewing latest posts and topics.

E89 offside rear indicator suddenly intermittent not working

Post Reply
TONYMOR
Member
Member
Posts: 751
Joined: Sat Jan 07, 2012 9:05 pm

E89 offside rear indicator suddenly intermittent not working

Post by TONYMOR » Wed Aug 24, 2022 7:34 pm

My offside rear indicator suddenly developed an intermittent problem. One minute I’m indicating normally then suddenly it goes double speed and then corrects itself??
Any ideas?

User avatar
enuff_zed
Lifer
Lifer
Posts: 9222
Joined: Wed Oct 26, 2016 11:05 am
Location: Attleborough, Norfolk

E89 offside rear indicator suddenly intermittent not working

Post by enuff_zed » Wed Aug 24, 2022 7:38 pm

Well usually an indicator flashes double speed if the bulb at the other end of the car is not working.
Have you checked connections for the front and side bulbs?
E89 20i SDrive M Sport - mine
E85 2.5i auto - Vall's
E85 3.0i manual - Project Cheapskate
E85 3.0i auto - gone
E85 2.5si - gone
E85 2.2i - gone

User avatar
Zforbes
Member
Member
Posts: 383
Joined: Thu Sep 24, 2020 10:12 pm
Location: Ribble Valley

E89 offside rear indicator suddenly intermittent not working

Post by Zforbes » Wed Aug 24, 2022 7:40 pm

TONYMOR wrote: Wed Aug 24, 2022 7:34 pm My offside rear indicator suddenly developed an intermittent problem. One minute I’m indicating normally then suddenly it goes double speed and then corrects itself??
Any ideas?
Check for water in the unit, very common problem, best fixed with new unit or both as can be visually different due to fading.
E89 sDrive 35is Titan Silver Kansas Black Leather

User avatar
B21
Senior Member
Senior Member
Posts: 2307
Joined: Tue Oct 05, 2021 7:15 pm
Location: It never rains in Southern Caledonia

E89 offside rear indicator suddenly intermittent not working

Post by B21 » Wed Aug 24, 2022 8:53 pm

Zforbes wrote: Wed Aug 24, 2022 7:40 pm
TONYMOR wrote: Wed Aug 24, 2022 7:34 pm My offside rear indicator suddenly developed an intermittent problem. One minute I’m indicating normally then suddenly it goes double speed and then corrects itself??
Any ideas?
Check for water in the unit, very common problem, best fixed with new unit or both as can be visually different due to fading.
If it’s an E89 most likely, especially earlier cars with first generations of the tail lights…
Image

Heavily modded E89 20i MSport 2017-2022…Even more modded E89 35is 2021 onwards..

Stash36
Member
Member
Posts: 93
Joined: Tue Sep 08, 2020 7:43 pm

E89 offside rear indicator suddenly intermittent not working

Post by Stash36 » Wed Sep 07, 2022 1:57 pm

I've got a 2009 offside rear light if you need one, only replaced as it didn't match my new nearside lens due to fading as mentioned. 125 delivered.

wanatkinson
Newbie
Newbie
Posts: 23
Joined: Sun May 14, 2017 7:46 pm

E89 offside rear indicator suddenly intermittent not working

Post by wanatkinson » Fri Sep 23, 2022 12:07 pm

Another thing to perhaps look out for - One of my indicators went intermittently a couple of years ago. Then over winter it disappeared. Then when summer came round and I used the roof for the first time it came back. It still isn't fixed as it only happens rarely and I imagine it could be a pain to fix. Definitely happens when I use the roof then seems to settle down...
2011 E89 23i manual - "augmented" audio - Blue with cream leather.
Image

DevonPaul
Member
Member
Posts: 106
Joined: Tue Aug 11, 2015 12:35 pm

E89 offside rear indicator suddenly intermittent not working

Post by DevonPaul » Fri Sep 23, 2022 12:37 pm

As said, double speed usually indicates (sorry) a failed bulb.

If it is coming and going it could be a bulb that is failing, or a direty connection.

Put the indicators on then wobble/tap them to see which one stops flashing, my money is on the repeater on the side, either that or the one that's hardest to get to :)
2006 Imola Z4MC (wife's shopping trolley)
1990 Toyota Carina (Started as a free family heirloom, now apparently a Classic)
2016 Toyota Avensis 1.6D (yup, the *really* slow one).
2011 TDM900

flybobbie
Lifer
Lifer
Posts: 3243
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

E89 offside rear indicator suddenly intermittent not working

Post by flybobbie » Fri Sep 23, 2022 7:20 pm

Loads of electronics at bottom of indicator. Once significant moisture gets in it fails.
20201217_163847.jpg
20201217_163847.jpg (106.36 KiB) Viewed 78 times

User avatar
CFSD
Newbie
Newbie
Posts: 41
Joined: Thu Jan 09, 2020 4:59 pm
Location: Cheshire

E89 offside rear indicator suddenly intermittent not working

Post by CFSD » Tue Sep 27, 2022 8:54 am

I've had the same issue on my rear left.
The seals leak and condensation/water will collect on the LED board. eventually it fails.
The board itself isn't a replaceable part, it's a whole new rear cluster to fix I'm afraid.
That said, the replacement itself is dead easy, if you've got a trim tool for the plastic plugs.

Post Reply