Not joined yet? Register for free and enjoy features such as alerts, private messaging and viewing latest posts and topics.

Passenger airbag retrofit...

2003 - 2009, roadster, coupe, facelift
User avatar
IAmOrion
Senior Member
Senior Member
Posts: 1540
Joined: Mon May 22, 2017 8:29 pm
Location: Cambridge, UK

Passenger airbag retrofit...

Post by IAmOrion » Tue Jun 23, 2020 3:19 pm

Has anyone done the passenger air bag switch retrofit? I’ve fitted the switch, the wiring was already in place (2003 E85) and connected the Passenger airbag off LED, but nothing happens. At least, the led never turns on.

I’ve checked the status of the switch using my C310+ and it correctly shows the switch is turning on/off accordingly.

The retrofit mentions coding - does anyone know what needs to be coded? I suspect this is what I’m missing as I haven’t yet coded anything but don’t know what I’m supposed to code with what tool.

Any info greatly appreciated.
Image
Carly/ISTA/INPA/EWS Key Coding, Cambridge CB22 Area - FREE (Donations accepted but never expected) - viewtopic.php?f=13&t=110150
Facebook: https://www.facebook.com/groups/Z4DIYCustomMods/

Wookster78
Member
Member
Posts: 218
Joined: Fri May 01, 2020 5:02 pm
Location: Chesham, UK

Passenger airbag retrofit...

Post by Wookster78 » Tue Jun 23, 2020 3:27 pm

Hi, yes I have done this and you need to code it using ISTA-P rheingold, this software allows for retrofitting different options for the car. You need to select the passenger airbag bypass retrofit and the programme will essentially programme it in for you. Takes about 20 mins or so and make sure you battery is hooked up to a charger or you will have all sorts of problems :thumbsup:
2004 E85 3.0i, LCI xenons, red sports interior, backbox delete, twin pipe conversion, diff ratio upgrade, coilovers, clear rear lights, cup holders, Sapphire black
2014 F31 M Performance Pack, Avin headunit, LED headlights

User avatar
IAmOrion
Senior Member
Senior Member
Posts: 1540
Joined: Mon May 22, 2017 8:29 pm
Location: Cambridge, UK

Passenger airbag retrofit...

Post by IAmOrion » Tue Jun 23, 2020 3:31 pm

Wookster78 wrote: Tue Jun 23, 2020 3:27 pm Hi, yes I have done this and you need to code it using ISTA-P rheingold, this software allows for retrofitting different options for the car. You need to select the passenger airbag bypass retrofit and the programme will essentially programme it in for you. Takes about 20 mins or so and make sure you battery is hooked up to a charger or you will have all sorts of problems :thumbsup:
Ahh thanks, I guess that’s why it’s not working ha

Correct me if I’m wrong but ISTA-P doesn’t work with k+d can cables does it? I always thought only Ista D / Inpa / ncs / dis / sss worked but not ista p?
Image
Carly/ISTA/INPA/EWS Key Coding, Cambridge CB22 Area - FREE (Donations accepted but never expected) - viewtopic.php?f=13&t=110150
Facebook: https://www.facebook.com/groups/Z4DIYCustomMods/

Wookster78
Member
Member
Posts: 218
Joined: Fri May 01, 2020 5:02 pm
Location: Chesham, UK

Passenger airbag retrofit...

Post by Wookster78 » Tue Jun 23, 2020 3:36 pm

Hi,
Yes I have it working with a usb k-d can câble obviously selected to K for the z4. You just need to have the icom simulator running using ISTA-P loader to launch the programme and it works fine.
Last edited by Wookster78 on Tue Jun 23, 2020 3:39 pm, edited 1 time in total.
2004 E85 3.0i, LCI xenons, red sports interior, backbox delete, twin pipe conversion, diff ratio upgrade, coilovers, clear rear lights, cup holders, Sapphire black
2014 F31 M Performance Pack, Avin headunit, LED headlights

User avatar
IAmOrion
Senior Member
Senior Member
Posts: 1540
Joined: Mon May 22, 2017 8:29 pm
Location: Cambridge, UK

Passenger airbag retrofit...

Post by IAmOrion » Tue Jun 23, 2020 3:38 pm

Wookster78 wrote: Tue Jun 23, 2020 3:36 pm Hi,
Yes I have it working with a usb k-d can câble obviously selected to K for the z4. You just need to have the icom simulator running and it works fine.
Ooh ok! I’ll have a hunt for ista-p now. (I have a few sources :))

Hopefully it’ll have a guide to setup the icom emulator.

Thanks for the heads up
Image
Carly/ISTA/INPA/EWS Key Coding, Cambridge CB22 Area - FREE (Donations accepted but never expected) - viewtopic.php?f=13&t=110150
Facebook: https://www.facebook.com/groups/Z4DIYCustomMods/

Wookster78
Member
Member
Posts: 218
Joined: Fri May 01, 2020 5:02 pm
Location: Chesham, UK

Passenger airbag retrofit...

Post by Wookster78 » Tue Jun 23, 2020 3:40 pm

Good luck :thumbsup:
2004 E85 3.0i, LCI xenons, red sports interior, backbox delete, twin pipe conversion, diff ratio upgrade, coilovers, clear rear lights, cup holders, Sapphire black
2014 F31 M Performance Pack, Avin headunit, LED headlights

User avatar
IAmOrion
Senior Member
Senior Member
Posts: 1540
Joined: Mon May 22, 2017 8:29 pm
Location: Cambridge, UK

Passenger airbag retrofit...

Post by IAmOrion » Fri Jun 26, 2020 12:34 pm

Wookster78 wrote: Tue Jun 23, 2020 3:40 pm Good luck :thumbsup:
So I got around to this today. I completed the retrofit via ista-p, it said completed successfully, but still my passenger airbag light doesn’t turn on when switch is off.

I’ve tested the led in the light, it’s working (at least, it’s working via a multimeter and glows when testing forward voltage). The switch appears to work also since my c310 correctly changes to on/off as I change switch position.

I’m a little confused as the led has Only 2 pins next to each other , but the plug has 2 pins with a 1 pin spacing. Meaning only 1 pin connects. I’ve tried looking for wiring diagram etc but I just can’t find any explanation!

Any thoughts?
Image
Carly/ISTA/INPA/EWS Key Coding, Cambridge CB22 Area - FREE (Donations accepted but never expected) - viewtopic.php?f=13&t=110150
Facebook: https://www.facebook.com/groups/Z4DIYCustomMods/

User avatar
IAmOrion
Senior Member
Senior Member
Posts: 1540
Joined: Mon May 22, 2017 8:29 pm
Location: Cambridge, UK

Passenger airbag retrofit...

Post by IAmOrion » Fri Jun 26, 2020 12:36 pm

IAmOrion wrote: Fri Jun 26, 2020 12:34 pm
Wookster78 wrote: Tue Jun 23, 2020 3:40 pm Good luck :thumbsup:
So I got around to this today. I completed the retrofit via ista-p, it said completed successfully, but still my passenger airbag light doesn’t turn on when switch is off.

I’ve tested the led in the light, it’s working (at least, it’s working via a multimeter and glows when testing forward voltage). The switch appears to work also since my c310 correctly changes to on/off as I change switch position.

I’m a little confused as the led has Only 2 pins next to each other , but the plug has 2 pins with a 1 pin spacing. Meaning only 1 pin connects. I’ve tried looking for wiring diagram etc but I just can’t find any explanation!

Any thoughts?
Attachments
image.jpg
image.jpg (379.86 KiB) Viewed 640 times
2EF3EFBF-3578-4506-BEC0-722562ADA1D2.jpeg
2EF3EFBF-3578-4506-BEC0-722562ADA1D2.jpeg (299.19 KiB) Viewed 640 times
Image
Carly/ISTA/INPA/EWS Key Coding, Cambridge CB22 Area - FREE (Donations accepted but never expected) - viewtopic.php?f=13&t=110150
Facebook: https://www.facebook.com/groups/Z4DIYCustomMods/

Wookster78
Member
Member
Posts: 218
Joined: Fri May 01, 2020 5:02 pm
Location: Chesham, UK

Passenger airbag retrofit...

Post by Wookster78 » Fri Jun 26, 2020 8:11 pm

Hi, yeah you are correct both pins should touch a wire, my led looks different to yours but the plug is the same, maybe they did different led configurations for early and later year vehicles. See pics of mine, if you just move one of the wires over I think it should work fine from looking at yours
Attachments
872F2603-B34F-4236-ABF0-9E7A393860CB.jpeg
872F2603-B34F-4236-ABF0-9E7A393860CB.jpeg (335.35 KiB) Viewed 618 times
8CB787DB-5DF1-4949-849A-D3B731765240.jpeg
8CB787DB-5DF1-4949-849A-D3B731765240.jpeg (309.86 KiB) Viewed 618 times
2004 E85 3.0i, LCI xenons, red sports interior, backbox delete, twin pipe conversion, diff ratio upgrade, coilovers, clear rear lights, cup holders, Sapphire black
2014 F31 M Performance Pack, Avin headunit, LED headlights

User avatar
IAmOrion
Senior Member
Senior Member
Posts: 1540
Joined: Mon May 22, 2017 8:29 pm
Location: Cambridge, UK

Passenger airbag retrofit...

Post by IAmOrion » Fri Jun 26, 2020 8:51 pm

Wookster78 wrote: Fri Jun 26, 2020 8:11 pm Hi, yeah you are correct both pins should touch a wire, my led looks different to yours but the plug is the same, maybe they did different led configurations for early and later year vehicles. See pics of mine, if you just move one of the wires over I think it should work fine from looking at yours
Ahhhh interesting!! Thanks for the pictures that actually helps a bunch. I did try swapping the wires around but still no joys.

I’ll try and find one matching the part number I can see on yours though - it’s diff to the one I have

I’m also not actually 100% the coding did work now. When I read it back, it correctly states mfsw retrofit (I know that doesn’t require coding as such, it just adds it to the spec stored in the cars info) but still doesn’t state passenger airbag anywhere
Image
Carly/ISTA/INPA/EWS Key Coding, Cambridge CB22 Area - FREE (Donations accepted but never expected) - viewtopic.php?f=13&t=110150
Facebook: https://www.facebook.com/groups/Z4DIYCustomMods/

Wookster78
Member
Member
Posts: 218
Joined: Fri May 01, 2020 5:02 pm
Location: Chesham, UK

Passenger airbag retrofit...

Post by Wookster78 » Fri Jun 26, 2020 9:14 pm

Ah yeah after I coded mine ISTAP does show it as an option fitted to the car so does sound like it may not have worked, I retrofitted the cruise control and that now also shows on the options list
2004 E85 3.0i, LCI xenons, red sports interior, backbox delete, twin pipe conversion, diff ratio upgrade, coilovers, clear rear lights, cup holders, Sapphire black
2014 F31 M Performance Pack, Avin headunit, LED headlights

User avatar
IAmOrion
Senior Member
Senior Member
Posts: 1540
Joined: Mon May 22, 2017 8:29 pm
Location: Cambridge, UK

Passenger airbag retrofit...

Post by IAmOrion » Fri Jun 26, 2020 10:34 pm

Wookster78 wrote: Fri Jun 26, 2020 9:14 pm Ah yeah after I coded mine ISTAP does show it as an option fitted to the car so does sound like it may not have worked, I retrofitted the cruise control and that now also shows on the options list
I mean, it did something because now my airbag warning light keeps coming on :( I clear it, 2 mins later it’s back. And that’s purely started since attempting to code the retrofit.

Also, ista-p no longer connects. Well, it connects, but can’t read vin anymore. If I enter vin manually it then complains about operation order code or something.

My INPA and ISTA won’t connect anymore either :(

No idea why. Bloody windows 10 and ista is iffy I suppose

Might try create a WXP VM
Image
Carly/ISTA/INPA/EWS Key Coding, Cambridge CB22 Area - FREE (Donations accepted but never expected) - viewtopic.php?f=13&t=110150
Facebook: https://www.facebook.com/groups/Z4DIYCustomMods/

Wookster78
Member
Member
Posts: 218
Joined: Fri May 01, 2020 5:02 pm
Location: Chesham, UK

Passenger airbag retrofit...

Post by Wookster78 » Fri Jun 26, 2020 11:10 pm

I am actually running ISTA-P on windows 10 and works fine on the z4 but not on the F10 comes up with some weird error and also can’t read the Vin and won’t accept manually, did have that when I first connected the z4 but changed the usb com port to 1 and amended some of the .ini files and it worked, was a YouTube video on it not connecting the car but does work fine now on window 10
2004 E85 3.0i, LCI xenons, red sports interior, backbox delete, twin pipe conversion, diff ratio upgrade, coilovers, clear rear lights, cup holders, Sapphire black
2014 F31 M Performance Pack, Avin headunit, LED headlights

User avatar
IAmOrion
Senior Member
Senior Member
Posts: 1540
Joined: Mon May 22, 2017 8:29 pm
Location: Cambridge, UK

Passenger airbag retrofit...

Post by IAmOrion » Fri Jun 26, 2020 11:12 pm

Wookster78 wrote: Fri Jun 26, 2020 11:10 pm I am actually running ISTA-P on windows 10 and works fine on the z4 but not on the F10 comes up with some weird error and also can’t read the Vin and won’t accept manually, did have that when I first connected the z4 but changed the usb com port to 1 and amended some of the .ini files and it worked, was a YouTube video on it not connecting the car but does work fine now on window 10
Ahh I’ll have to take a look next week when I get a chance. Damn springs snapped today so other priorities now :(
Image
Carly/ISTA/INPA/EWS Key Coding, Cambridge CB22 Area - FREE (Donations accepted but never expected) - viewtopic.php?f=13&t=110150
Facebook: https://www.facebook.com/groups/Z4DIYCustomMods/

Wookster78
Member
Member
Posts: 218
Joined: Fri May 01, 2020 5:02 pm
Location: Chesham, UK

Passenger airbag retrofit...

Post by Wookster78 » Fri Jun 26, 2020 11:18 pm

Ah keeps you busy, I get bored if something does not go wrong and I have nothing to fix, then I end up going around looking for something that not quite perfect and breaking it so I can fix it again :rofl:
2004 E85 3.0i, LCI xenons, red sports interior, backbox delete, twin pipe conversion, diff ratio upgrade, coilovers, clear rear lights, cup holders, Sapphire black
2014 F31 M Performance Pack, Avin headunit, LED headlights

Post Reply