Newbie from Glasgow

First port of call for new members
JamboZ4
Newbie
Newbie
Posts: 10
Joined: Thu Mar 14, 2019 9:59 pm

Newbie from Glasgow

Post by JamboZ4 » Thu Mar 14, 2019 10:06 pm

Hey guys just picked up my 2004 e85 2.2 SE today with only 63k on the clock and could not be happier espcially since my last car was a 1.2 corsa c :rofl:
I have a photo but do not know how to add it on to this thread :| some advice would be welcome

Mr Tidy
Lifer
Lifer
Posts: 8584
Joined: Wed Jul 02, 2014 12:18 pm
Location: Berkshire

Newbie from Glasgow

Post by Mr Tidy » Thu Mar 14, 2019 10:13 pm

Hi and welcome. :thumbsup:

Must feel like a rocket after a 1.2 Corsa. :lol:

To post a photo just scroll down from where you type the message and you'll see an "Add Files" tab. If you click on that you can browse your photos to find the one you want. Hope to see your car soon!
Z4 3.0Si Sport - Coupe for added stiffness!
Current - Montego Blue, Pearl Grey, Cirrus trim & 295s. Cruise, Storage and pdc. E91 325i as a DD.
Gone - Ruby Black, Pearl Grey & 135Ms. Xenons, heated seats and Professional speakers.

JamboZ4
Newbie
Newbie
Posts: 10
Joined: Thu Mar 14, 2019 9:59 pm

Newbie from Glasgow

Post by JamboZ4 » Thu Mar 14, 2019 10:33 pm

Haha yeah it sure does!! I tried the add files button but just put me straight on to the camera on my phone and would not let me pick from my album :headbang: I will take fresh photo's tomorrow hopefully in the sunshine.

JamboZ4
Newbie
Newbie
Posts: 10
Joined: Thu Mar 14, 2019 9:59 pm

Newbie from Glasgow

Post by JamboZ4 » Thu Mar 14, 2019 10:36 pm

On my drive home from the dealer today i noticed the runflat indicator come on so i checked the psi in the manual and went to put some air in thw tyres but low and behold the back right valve cap is one of those cheap metal ones that is now stuck :headbang: any advice on how to get it off without damage to the valve ??

User avatar
Big Andra
Member
Member
Posts: 182
Joined: Tue Jul 17, 2018 1:45 pm
Location: Carluke Scotlandshire

Newbie from Glasgow

Post by Big Andra » Thu Mar 14, 2019 11:00 pm

Welcome to the forum. I'd give the valve cap a tickle with some pliers while holding the valve with a second pair.

Mr Tidy
Lifer
Lifer
Posts: 8584
Joined: Wed Jul 02, 2014 12:18 pm
Location: Berkshire

Newbie from Glasgow

Post by Mr Tidy » Thu Mar 14, 2019 11:05 pm

Big Andra wrote:
Thu Mar 14, 2019 11:00 pm
Welcome to the forum. I'd give the valve cap a tickle with some pliers while holding the valve with a second pair.
+1 - I had the same problem on a 1 Series.

Sorry about the photo OP - I never post from my phone as I save the photos onto my PC. :roll:
Z4 3.0Si Sport - Coupe for added stiffness!
Current - Montego Blue, Pearl Grey, Cirrus trim & 295s. Cruise, Storage and pdc. E91 325i as a DD.
Gone - Ruby Black, Pearl Grey & 135Ms. Xenons, heated seats and Professional speakers.

User avatar
buzyg
Lifer
Lifer
Posts: 14322
Joined: Fri May 20, 2011 6:11 pm
Location: Cornwall

Newbie from Glasgow

Post by buzyg » Thu Mar 14, 2019 11:46 pm

Welcome to the forum. :)
Image

JamboZ4
Newbie
Newbie
Posts: 10
Joined: Thu Mar 14, 2019 9:59 pm

Newbie from Glasgow

Post by JamboZ4 » Thu Mar 14, 2019 11:49 pm

Thanks for the advice guys :thumbsup: Will give it a try tomorrow and hopefully get it off and sort out that run flat indicator

GixerWill
Newbie
Newbie
Posts: 34
Joined: Sat Feb 23, 2019 3:36 am

Newbie from Glasgow

Post by GixerWill » Fri Mar 15, 2019 12:50 am

Welcome JamboZ4 :thumbsup:

I am a new forum member myself, also from Glasgow.

When I press the add files button on my phone I get a 'choose an action' button. Then press on 'Files'. Then find wherever the image/s are stored, mine are within: Gallery. I then have to compress my images as they are too large. This is on an Android, perhaps it may be different on IOS.
Screenshot_20190314-234045_Android System-min.jpg
Screenshot_20190314-234045_Android System-min.jpg (75.64 KiB) Viewed 153 times

Online
Silva1
Member
Member
Posts: 125
Joined: Sun Oct 18, 2015 11:03 am

Newbie from Glasgow

Post by Silva1 » Fri Mar 15, 2019 12:53 am

Welcome along

From Glasgow also :thumbsup:

JamboZ4
Newbie
Newbie
Posts: 10
Joined: Thu Mar 14, 2019 9:59 pm

Newbie from Glasgow

Post by JamboZ4 » Fri Mar 15, 2019 7:32 am

Thanks GixerWill that done the trick here is the first photo of my little beauty :D
Attachments
20190314_150322.jpg
20190314_150322.jpg (199.16 KiB) Viewed 138 times

MefiEcosse
Senior Member
Senior Member
Posts: 1346
Joined: Sat Jul 11, 2015 4:11 pm
Location: West Lothian

Newbie from Glasgow

Post by MefiEcosse » Fri Mar 15, 2019 8:05 am

Welcome aboard! :thumbsup:
Looks like a very nice Zed! :driving:
Alpina Roaster S Lux #310 - Titanium Silver
Sold - going to miss her! E85 2.5i Titanium Silver 2003 - Stormworks V1 - Sound Generator - Whippy - Zito 935's -

User avatar
jabber
Senior Member
Senior Member
Posts: 1876
Joined: Mon Jul 05, 2010 9:23 am
Location: Hampshire

Newbie from Glasgow

Post by jabber » Fri Mar 15, 2019 8:43 am

Welcome to the forum :thumbsup:
10 E89 Z4 3.0 Black auto
68 focus st line x
Gone 04 E85 z4 3.0 Maldives blue smg
Gone 15 F23 220d lux convertible silver auto

User avatar
redtailed78
Member
Member
Posts: 94
Joined: Sun May 27, 2018 6:39 pm
Location: Cumbernauld

Newbie from Glasgow

Post by redtailed78 » Fri Mar 15, 2019 10:21 am

Welcome, cracking car :thumbsup:

Loads of people from around Glasgow on here now :)
2006 3.0lSi M Sport :driving:
19" 313 alloys
Brembo Brake Upgrade
K&N Panel Filter
Back Box Delete

Online
User avatar
Jim S
Member
Member
Posts: 72
Joined: Mon Dec 26, 2016 9:59 pm
Location: Ayrshire, Scotland

Newbie from Glasgow

Post by Jim S » Fri Mar 15, 2019 12:57 pm

Nice looking car. Love the colour.
I’m from Ayrshire, so not too far away.
Happy motoring. :driving:

Post Reply