19” New alloys issue, help!

2003 - 2009, roadster, coupe, facelift
rally-chris
Member
Member
Posts: 693
Joined: Wed Jul 26, 2017 12:32 pm
Location: Newbury, Berks UK

19” New alloys issue, help!

Post by rally-chris » Thu Jan 10, 2019 4:00 pm

SamP84 wrote:
Thu Jan 10, 2019 11:46 am
MACK wrote:
Thu Jan 10, 2019 11:41 am
SamP84 wrote:
Thu Jan 10, 2019 12:11 am
I’ve taken the long bolts off and put bolts with a 26mm thread on which seems a pretty standard bolt. Do I need to go down to 19mm thread, doesn’t seem a lot thread.
The standard bolt has a 26mm threaded section and is circa 45mm overall length including the head. If this is what you've but on stick with that.
Hi Mack,

The long bolts were replaced with the Ones below. I just don’t understand how these could be too long. Am I missing something?
The wheel bolts will only have the same effective engagement length into the wheel hub as your original MV2 setup if the replacement wheels are the same ‘thickness’ between the back of the mounting face and the conical seat for the bolts as the oem wheels.

As the wheels are aftermarket they *might* be thinner and therefore the original bolts protrude further behind the wheel hub?

Chris
08 Z4 3.0si Sport Coupe in Montego Blue

rally-chris
Member
Member
Posts: 693
Joined: Wed Jul 26, 2017 12:32 pm
Location: Newbury, Berks UK

19” New alloys issue, help!

Post by rally-chris » Thu Jan 10, 2019 4:02 pm

Another point - do the new wheel have the correct centre bore or have correctly sized spigot rings fitted? Otherwise noise could be the wheel shifting radially as the axle rotates and this would be a dangerous situation.
08 Z4 3.0si Sport Coupe in Montego Blue

Online
SamP84
Member
Member
Posts: 134
Joined: Wed May 30, 2018 2:43 pm

19” New alloys issue, help!

Post by SamP84 » Thu Jan 10, 2019 4:18 pm

rally-chris wrote:
Thu Jan 10, 2019 4:00 pm
SamP84 wrote:
Thu Jan 10, 2019 11:46 am
MACK wrote:
Thu Jan 10, 2019 11:41 am
The standard bolt has a 26mm threaded section and is circa 45mm overall length including the head. If this is what you've but on stick with that.
Hi Mack,

The long bolts were replaced with the Ones below. I just don’t understand how these could be too long. Am I missing something?
The wheel bolts will only have the same effective engagement length into the wheel hub as your original MV2 setup if the replacement wheels are the same ‘thickness’ between the back of the mounting face and the conical seat for the bolts as the oem wheels.

As the wheels are aftermarket they *might* be thinner and therefore the original bolts protrude further behind the wheel hub?

Chris
Hi Chris,

This is a possible and what I first suspected. The next step is to get 19mm thread bolts... this is very short though... I’m going to jack up the wheels and rotate them as my Jack has been delivered.

The wheels I have fitted have been fitted to a few Z4 E85/6 Si cars with no issues.

When I turn the front steering wheel nothing fouls and when I bounce suspension there is no rubbing.

What a palarva. Really appreciate people’s input.

Online
SamP84
Member
Member
Posts: 134
Joined: Wed May 30, 2018 2:43 pm

19” New alloys issue, help!

Post by SamP84 » Thu Jan 10, 2019 4:22 pm

rally-chris wrote:
Thu Jan 10, 2019 4:02 pm
Another point - do the new wheel have the correct centre bore or have correctly sized spigot rings fitted? Otherwise noise could be the wheel shifting radially as the axle rotates and this would be a dangerous situation.
Again, thank you, I will check this... the tyre fitter fitting would surely spot this. These wheels were recommended by the alloy wheel shop I bought them.

Tonight I hope to report back better news.

User avatar
mr wilks
Lifer
Lifer
Posts: 19458
Joined: Wed Jul 04, 2012 10:02 pm
Location: Lancs or Normandy , i don't mind which

19” New alloys issue, help!

Post by mr wilks » Thu Jan 10, 2019 5:48 pm

SamP84 wrote:
Thu Jan 10, 2019 4:22 pm
rally-chris wrote:
Thu Jan 10, 2019 4:02 pm
Another point - do the new wheel have the correct centre bore or have correctly sized spigot rings fitted? Otherwise noise could be the wheel shifting radially as the axle rotates and this would be a dangerous situation.


Again, thank you, I will check this... the tyre fitter fitting would surely spot this. These wheels were recommended by the alloy wheel shop I bought them.

Tonight I hope to report back better news.
Ive had 4 sets of Veemann wheels & all have been the correct centre bore & fitted straight on with original Bmw wheelbolts
Are you 100& sure the fronts are not Et 35 ?
E86
E85
Grey///MR
Si E85
E89 23i
Si E85
E86
3.0Si E85
Imola///MR
35i Msport 6spd
E86
Ti ///MR
E86

35is :driving:


Image




https://www.instagram.com/andybmwheels/

Online
SamP84
Member
Member
Posts: 134
Joined: Wed May 30, 2018 2:43 pm

19” New alloys issue, help!

Post by SamP84 » Thu Jan 10, 2019 6:27 pm

mr wilks wrote:
Thu Jan 10, 2019 5:48 pm
SamP84 wrote:
Thu Jan 10, 2019 4:22 pm
rally-chris wrote:
Thu Jan 10, 2019 4:02 pm
Another point - do the new wheel have the correct centre bore or have correctly sized spigot rings fitted? Otherwise noise could be the wheel shifting radially as the axle rotates and this would be a dangerous situation.


Again, thank you, I will check this... the tyre fitter fitting would surely spot this. These wheels were recommended by the alloy wheel shop I bought them.

Tonight I hope to report back better news.
Ive had 4 sets of Veemann wheels & all have been the correct centre bore & fitted straight on with original Bmw wheelbolts
Are you 100& sure the fronts are not Et 35 ?
Going to check when I get home, my order from the shop I Bought the wheels from was ET35 front and ET42 rear. Cheers Mr Wilks.

Online
SamP84
Member
Member
Posts: 134
Joined: Wed May 30, 2018 2:43 pm

19” New alloys issue, help!

Post by SamP84 » Thu Jan 10, 2019 11:18 pm

I found the issue, will update when I have spoken to the relevant party. :headbang:

User avatar
Nictrix
Lifer
Lifer
Posts: 3474
Joined: Mon Aug 18, 2014 9:59 pm
Location: Paisley

19” New alloys issue, help!

Post by Nictrix » Fri Jan 11, 2019 12:32 pm

Is it staggered wheels and they have put a front on the rear?
E89 2010 23i M Sport Black with Black leather

Online
SamP84
Member
Member
Posts: 134
Joined: Wed May 30, 2018 2:43 pm

19” New alloys issue, help!

Post by SamP84 » Fri Jan 11, 2019 2:46 pm

Nictrix wrote:
Fri Jan 11, 2019 12:32 pm
Is it staggered wheels and they have put a front on the rear?
I wish... even more stupid... tyre fitter put long bolts back in even though spacers removed. Long story short it has made a mess of the disc baking plates that sit behind the discs (obvs). Car on its way on a low loader to local specialist I trust. The tyre fitters are denying any knowledge... of course. I could fight it but I just don't have the time and energy.

greg81
Senior Member
Senior Member
Posts: 1679
Joined: Thu Mar 02, 2017 6:33 pm

19” New alloys issue, help!

Post by greg81 » Fri Jan 11, 2019 4:00 pm

SamP84 wrote:
Fri Jan 11, 2019 2:46 pm
Nictrix wrote:
Fri Jan 11, 2019 12:32 pm
Is it staggered wheels and they have put a front on the rear?
I wish... even more stupid... tyre fitter put long bolts back in even though spacers removed. Long story short it has made a mess of the disc baking plates that sit behind the discs (obvs). Car on its way on a low loader to local specialist I trust. The tyre fitters are denying any knowledge... of course. I could fight it but I just don't have the time and energy.
Did you provide them with the shorter bolts knowing you were using spacers anymore?

Online
SamP84
Member
Member
Posts: 134
Joined: Wed May 30, 2018 2:43 pm

19” New alloys issue, help!

Post by SamP84 » Fri Jan 11, 2019 5:16 pm

greg81 wrote:
Fri Jan 11, 2019 4:00 pm
SamP84 wrote:
Fri Jan 11, 2019 2:46 pm
Nictrix wrote:
Fri Jan 11, 2019 12:32 pm
Is it staggered wheels and they have put a front on the rear?
I wish... even more stupid... tyre fitter put long bolts back in even though spacers removed. Long story short it has made a mess of the disc baking plates that sit behind the discs (obvs). Car on its way on a low loader to local specialist I trust. The tyre fitters are denying any knowledge... of course. I could fight it but I just don't have the time and energy.
Did you provide them with the shorter bolts knowing you were using spacers anymore?
I did indeed.

User avatar
Jl-c
Member
Member
Posts: 308
Joined: Sun Sep 02, 2018 12:47 am
Location: Shropshire

19” New alloys issue, help!

Post by Jl-c » Fri Jan 11, 2019 11:47 pm

Sorry to hear but in my experience the average tyre fitter has an iq smaller than their shoe size. I know there are exceptions and I have found a couple I trust implicitly but they are few and far between. Worse still, many just don't give a toss, it's not their car :x
E86 Z4 3.0si coupé facelift blue (with heated M seats, bluetooth, privacy glass, xenons, M suspension, 160Gb Ipod. etc)
Porsche 997 C2S black, VW Passat 2.0L black, Mazda Eunos 1.8 yellow.

Online
SamP84
Member
Member
Posts: 134
Joined: Wed May 30, 2018 2:43 pm

19” New alloys issue, help!

Post by SamP84 » Sat Jan 12, 2019 9:54 am

Jl-c wrote:
Fri Jan 11, 2019 11:47 pm
Sorry to hear but in my experience the average tyre fitter has an iq smaller than their shoe size. I know there are exceptions and I have found a couple I trust implicitly but they are few and far between. Worse still, many just don't give a toss, it's not their car :x
Well it’s happened, it’s annoying but it’s one of life’s little tests. So chuffed with how the wheels look! Just need to get it back from the garage now lol.

Thanks all for input, very kind.

Post Reply