Any one added a sub to the OEM system

Post Reply
User avatar
JimsZ
Member
Member
Posts: 325
Joined: Thu Oct 29, 2015 10:15 pm
Location: Heathrow

Any one added a sub to the OEM system

Post by JimsZ » Sat Nov 07, 2015 10:56 pm

That can confirm how they did it or do I just get it done at an audio shop :D
E89/28i Msport road, Zx10r track...YAY. The count down begins... 4 days in Jerez Oct 18 Almeria done April 2018 : :evil:

User avatar
markeg
Lifer
Lifer
Posts: 8096
Joined: Thu Feb 16, 2012 7:05 pm
Location: Lincolnshire Wolds

Re: Any one added a sub to the OEM system

Post by markeg » Sun Nov 08, 2015 11:07 am

Have you looked at this thread?
previous: Alpina Roadster S, #108: gone
current: MB C-class
"veni, vidi, velcro - I came, I saw, I stuck around..."

User avatar
JimsZ
Member
Member
Posts: 325
Joined: Thu Oct 29, 2015 10:15 pm
Location: Heathrow

Re: Any one added a sub to the OEM system

Post by JimsZ » Thu Nov 19, 2015 9:28 pm

Cheers, good read. :thumbsup:

I was thinking a simple speaker upgrade and a sub... things are never that simple though are they :rofl:
E89/28i Msport road, Zx10r track...YAY. The count down begins... 4 days in Jerez Oct 18 Almeria done April 2018 : :evil:

User avatar
envy
Senior Member
Senior Member
Posts: 1325
Joined: Wed Oct 27, 2010 7:54 pm
Location: Derby/ Notts

Re: Any one added a sub to the OEM system

Post by envy » Fri Nov 20, 2015 12:20 am

i've put an amp and sub in the boot of mine and it makes one hell of a difference to the standard speaker system.

i had it done by a local professional audio installer, they had to take a feed from the back of the stereo and add some form of converter to isolate the bass. they charged about £120 all in for the work (including converter and amp wiring) as I already had the sub and amp.

people hark on about how poor the standard system is.... which it is to be fair, and having done this to my previous e89 too, i wouldnt pay for the premium system when this does the job extremely well

Post Reply