Not joined yet? Register for free and enjoy features such as alerts, private messaging and viewing latest posts and topics.

Key fob dead

flybobbie
Lifer
Lifer
Posts: 3448
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

Key fob dead

Post by flybobbie » Wed Jan 25, 2023 10:33 pm

So drove today, back DSC abs like christmas tree on. No hill start, so surprising how you after be quick off the mark.
Something else i noticed, ebrake on light flickering, like a bad contact somewhere.
Abs dsc warning goes when engine is restarted.
Now trying to find the common denominator of;
6E30DSC hyd. ctl. unit press. sense plausibility,
6570 DSC interface,
63F1EPS steering wheel angle.


Also the B4 Bilsteins i fitted whilst driving today made roof and mirrors resonate, stopped when i dropped tyre pressures down from 38f and 40r (what i have run for years) to 35psi all round. (Made no difference day later).
Last edited by flybobbie on Thu Jan 26, 2023 8:32 pm, edited 1 time in total.

flybobbie
Lifer
Lifer
Posts: 3448
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

Key fob dead

Post by flybobbie » Wed Jan 25, 2023 11:50 pm

Something i will look at, the scuttle drains.
I seem to remember one is above the abs unit on the left side.
Check for any corrosion on the abs plug because everything abs, brakes, etc. goes to this plug..

flybobbie
Lifer
Lifer
Posts: 3448
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

Key fob dead

Post by flybobbie » Thu Jan 26, 2023 8:29 pm

So cleaned abs plug, made no difference. Fault came back up.
So went on a run with Foxwell set to wheel sensor in graph mode, set to rear wheels, record mode. Abs warning came up again.
It clears on restart.

The two speed lines would match on the straights but would see a random spike on the left.
But having fitted the B4 shocks, there seems a vibration being picked by the mirror glass and roof rattle.
Never seen that with B6 shocks.

So have a choice now, i have replacements wheel sensors, but they could be ok.
Replace the B4's back to the old B6's and see if any different.

Could the B4's be faulty or just not suited to the set up, unlucky resonance.
Is the system seeing some sort of random skip and flagging as a fault.

I should be able to download the graph, signed up to Foxwell, but now won't allow me to link.
Doesn't seem to allow replay on the reader itself.

flybobbie
Lifer
Lifer
Posts: 3448
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

Key fob dead

Post by flybobbie » Mon Jan 30, 2023 7:00 pm

So new wheel sensors fitted.
Hope this cures ABS problem.
Only driven few feet forward, but brake pedal seems more powerful.
One code that came up each time was abs pressure sensor plausibility.

flybobbie
Lifer
Lifer
Posts: 3448
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

Key fob dead

Post by flybobbie » Tue Jan 31, 2023 7:54 pm

No joy, 5 minutes into journey, bong.
I do notice the park brake icon when red, sometimes flickers, like a loose wire somewhere.

All resets if i switch off ignition/engine and restart. Then 10 minutes later, bong.

Something else i noticed on the obd readout was the accelerometers, they show a flickering longitudinal -0.13 average number.
Transverse says -0.2
Should these be zero when not moving.
I noticed when i lifted the carpet with seat removed a black box mounted to floor.
Think this might be the accelerometer.
Wonder if damp got to it.

flybobbie
Lifer
Lifer
Posts: 3448
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

Key fob dead

Post by flybobbie » Tue Jan 31, 2023 9:58 pm

It seems BMW supplier in their wisdom $$$$ built the pressure sensor into the abs unit, whereas for previous 20 odd year it was on the side, easy to replace.
Looking at minimum £300 rebuild.

Anyone have any links to diy repair.

User avatar
B21
Senior Member
Senior Member
Posts: 2966
Joined: Tue Oct 05, 2021 7:15 pm
Location: It never rains in Southern Caledonia

Key fob dead

Post by B21 » Tue Jan 31, 2023 10:45 pm

I think the lateral accelerometer is integrated into the DSC unit ….

Modded E89 20i MSport 2017-2022…Even more modded E89 35is 2021 onwards..details here.. https://www.dropbox.com/s/8h1vabklgzf4v ... t.pdf?dl=0


Image

flybobbie
Lifer
Lifer
Posts: 3448
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

Key fob dead

Post by flybobbie » Tue Jan 31, 2023 11:33 pm

Just a bit odd they don't read zero. Perhaps just noise. Thought there would be some hysteresis to stop being over sensitive.

Turning into a Apollo moon rocket problem.

Just don't want to waste 300 quid.
Last edited by flybobbie on Wed Feb 01, 2023 12:19 am, edited 1 time in total.

flybobbie
Lifer
Lifer
Posts: 3448
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

Key fob dead

Post by flybobbie » Tue Jan 31, 2023 11:35 pm

Brake pressure at foot pedal reads normal on obd.
Fact it resets on starting, wish it would just fail and be done with.

User avatar
B21
Senior Member
Senior Member
Posts: 2966
Joined: Tue Oct 05, 2021 7:15 pm
Location: It never rains in Southern Caledonia

Key fob dead

Post by B21 » Wed Feb 01, 2023 12:05 am

flybobbie wrote: Tue Jan 31, 2023 11:33 pm Just a bid odd they don't read zero. Perhaps just noise. Thought there would be some hysteresis to stop being over sensitive.

Turning into a Apollo moon rocket problem.

Just don't want to waste 300 quid.
Pass..are you sure someone is not spraying acetic acid every night into all your connectors? :tumbleweed:

Modded E89 20i MSport 2017-2022…Even more modded E89 35is 2021 onwards..details here.. https://www.dropbox.com/s/8h1vabklgzf4v ... t.pdf?dl=0


Image

flybobbie
Lifer
Lifer
Posts: 3448
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

Key fob dead

Post by flybobbie » Wed Feb 01, 2023 12:20 am

Someone or thing is telling me something.

flybobbie
Lifer
Lifer
Posts: 3448
Joined: Sat May 25, 2013 8:27 pm
Location: Stourbridge

Key fob dead

Post by flybobbie » Thu Feb 02, 2023 7:19 pm

So i noted today the error came up the bottom of a hill at a junction.
And when park brake applied the red P symbol flickers, like a bad connection then stays on normal.

Put an offer on an abs unit with the intention of swapping over the mechanical parts.
But gut feel is it's a wire problem.
Obd says
6030 parking brake ctl unit undervolt
6570 Interface dsc
6E30/not present dsc hyd. ctl unit press sense plausibilty
5F45/dsc brake fluid level too low
Brake fluid level not ok


Again it could be the level sensor is not a simple switch, but is shown as such in diagrams.
Unfortunately switch is molded into reservoir, so would need to replace all, need to see if it has any resistance or if there is a common supply with the flickering brake applied icon.

Post Reply