reset service light

Post Reply
Tysonwills
Member
Member
Posts: 142
Joined: Sat Jun 17, 2017 11:11 pm

reset service light

Post by Tysonwills » Fri Jan 19, 2018 9:26 am

Im am getting the service check light of the car up on a ramp.
I have went through all the options for brakes and oil etc and reset them all but I cant seem to reset this serivce light.
Anyone ideas its driving me nuts everytime i start the car the light pings and then goes out.
Its is a 2009 e89 2.3 sdrive with no idrive so i use the indicator stalk to reset everything

Online
User avatar
EssexZed
Member
Member
Posts: 250
Joined: Sun Apr 17, 2016 10:07 pm
Location: Colchester

reset service light

Post by EssexZed » Fri Jan 19, 2018 12:46 pm

Is it due an MOT?
Current: 2015 E89 35iS Valencia Orange
Previous: 2010 E89 23i Auto Space Grey

Tysonwills
Member
Member
Posts: 142
Joined: Sat Jun 17, 2017 11:11 pm

reset service light

Post by Tysonwills » Fri Jan 19, 2018 12:56 pm

not until september

User avatar
Ewazix
Lifer
Lifer
Posts: 3787
Joined: Sun May 02, 2010 5:30 pm
Location: Somerset

reset service light

Post by Ewazix » Fri Jan 19, 2018 4:06 pm

Similar problems have come up before, this one was down to a low battery I think

https://z4-forum.com/forum/viewtopic.ph ... 2291&hilit
2003 2.5 SE, low miles, Sterling Grey, 108's & Eagles, no stubby here! Unmolested.
2018 Cooper S Countryman
Fiesta Ecoboost T

cmp999
Member
Member
Posts: 60
Joined: Wed Oct 05, 2016 3:35 pm

reset service light

Post by cmp999 » Fri Jan 19, 2018 6:13 pm

I had the same, new battery and problem solved! :thumbsup:

User avatar
Kugaman1
Member
Member
Posts: 367
Joined: Sun Jul 30, 2017 6:16 pm
Location: North East Scotland

reset service light

Post by Kugaman1 » Fri Jan 19, 2018 6:40 pm

Yup, definitely a symptom of a dodgy battery.
Check out my posts, I fitted a new battery recently and got a slightly more powerful one.

User avatar
Ewazix
Lifer
Lifer
Posts: 3787
Joined: Sun May 02, 2010 5:30 pm
Location: Somerset

reset service light

Post by Ewazix » Fri Jan 19, 2018 6:54 pm

Like my e85 I think the e89 has a hidden service menu accessed via the dash (if you don't have iDrive) this gives vehicle data including volts - someone in the know might chip in how to access it on the e89 ..

or get a voltmeter on the battery + and - terminals with the engine OFF looking for a min 12.4 Volts. Anything below this indicates a battery or charging system problem.
If the battery volts are OK, then with the engine IDLING and all accessories OFF test the alternator by measuring the volts over the terminals again, a healthy alternator should now be reading between an additional 0.5 to 2 volts above the static test reading. Less than an this indicates an undercharging alternator, more than +2v suggests it's overcharging and needs service or replacement.
Then do a running load test with the engine at a steady 2000 RPM and all accessories on, (lights, radio, rear window/seat heaters etc) you should still get a reading of at least 0.5v above the static base reading.
2003 2.5 SE, low miles, Sterling Grey, 108's & Eagles, no stubby here! Unmolested.
2018 Cooper S Countryman
Fiesta Ecoboost T

Tysonwills
Member
Member
Posts: 142
Joined: Sat Jun 17, 2017 11:11 pm

reset service light

Post by Tysonwills » Wed Apr 11, 2018 1:25 pm

cmp999 when you replaced the battery did you need to register it to the car

User avatar
Smartbear
Lifer
Lifer
Posts: 7297
Joined: Wed Feb 05, 2014 6:54 pm
Location: In a barn

reset service light

Post by Smartbear » Wed Apr 11, 2018 1:35 pm

Tysonwills wrote:
Fri Jan 19, 2018 9:26 am
Im am getting the service check light of the car up on a ramp.
I have went through all the options for brakes and oil etc and reset them all but I cant seem to reset this serivce light.
Anyone ideas its driving me nuts everytime i start the car the light pings and then goes out.
Its is a 2009 e89 2.3 sdrive with no idrive so i use the indicator stalk to reset everything

If it’s due to wearing brake pads you can’t reset the warning unless you replace the sensor wire along with the pads.
Rob
Image

e89 Sdrive2.0 20i, plenty of mumbo & good economy=the thinking bears z4 :P
e89 Sdrive30i this ones busted, pass me another...
e85 3.0si, i foolishly sold my trouble free car...

cmp999
Member
Member
Posts: 60
Joined: Wed Oct 05, 2016 3:35 pm

reset service light

Post by cmp999 » Thu Apr 12, 2018 12:03 pm

Tysonwills wrote:
Wed Apr 11, 2018 1:25 pm
cmp999 when you replaced the battery did you need to register it to the car
Hi, the garage that fit the battery registered it to the car, it was a local garage not a dealership! :thumbsup:

Post Reply