Outside temp wrong after car wash

Post Reply
brian_mattey
Newbie
Newbie
Posts: 2
Joined: Mon Jul 16, 2018 4:12 pm

Outside temp wrong after car wash

Post by brian_mattey » Mon Jul 16, 2018 4:27 pm

Z4 E89 28i 2012

I had my car washed today ... hand wash not car wash (although with assorted jet wash things of course) ... and afterwards the outside temperature read at least 10c lower than it really was (read 17c was more like 27c).

I’ve found the sensor (passenger side front undertray in front of wheel) but it’s in a very recessed hole with nothing sticking out so I really don’t see how the wash could have affected it, and I can feel it’s not loose and no damage.

Has anyone ever had anything similar happen ... or is the sensor on the way out perhaps?

Thanks,

Brian

User avatar
RustyZ4
Lifer
Lifer
Posts: 3026
Joined: Fri Dec 14, 2007 7:23 pm
Location: Maidstone, Kent

Outside temp wrong after car wash

Post by RustyZ4 » Mon Jul 16, 2018 5:16 pm

Its possible if they got over exuberant with the jet wash, it might have shorted out, personally I would wait and see if it returns to normal,
Z4 Mineral Grey, 2.8 MSport Auto, lots of goodies
Z4 E85 3.0, now with son
Growing Old is Mandatory But Growing Up is Optional

User avatar
ronk
Lifer
Lifer
Posts: 8645
Joined: Tue Feb 24, 2009 11:50 am
Location: Durham

Outside temp wrong after car wash

Post by ronk » Mon Jul 16, 2018 10:35 pm

The cold water on the sensor maybe?
I know you’ve said it’s tucked away but if the wind can get in the water can as well !
You don't stop playing when you get old - You get old when you stop playing!
So I bought a 35is with all the toys to play with. :thumbsup:

brian_mattey
Newbie
Newbie
Posts: 2
Joined: Mon Jul 16, 2018 4:12 pm

Outside temp wrong after car wash

Post by brian_mattey » Tue Jul 17, 2018 1:43 pm

And today it’s ok :) so panic over. Waiting was indeed the thing to do.

Thanks,

Brian

User avatar
RustyZ4
Lifer
Lifer
Posts: 3026
Joined: Fri Dec 14, 2007 7:23 pm
Location: Maidstone, Kent

Outside temp wrong after car wash

Post by RustyZ4 » Tue Jul 17, 2018 1:51 pm

brian_mattey wrote:
Tue Jul 17, 2018 1:43 pm
And today it’s ok :) so panic over. Waiting was indeed the thing to do.

Thanks,

Brian
Probably all that could cold water getting sprayed over it in this heat, sent it into shock :rofl:
Z4 Mineral Grey, 2.8 MSport Auto, lots of goodies
Z4 E85 3.0, now with son
Growing Old is Mandatory But Growing Up is Optional

mcbutler
Member
Member
Posts: 538
Joined: Fri May 26, 2017 3:40 pm

Outside temp wrong after car wash

Post by mcbutler » Wed Jul 18, 2018 12:45 pm

Yeah, just a bit over sensortive!!

Post Reply