headlight washers not working

Discuss problems you have had or are having with your Z4
User avatar
paddy wright
Lifer
Lifer
Posts: 6619
Joined: Sun Jan 06, 2008 1:00 pm
Location: south yorkshire

headlight washers not working

Post by paddy wright » Tue Sep 15, 2009 11:17 pm

My headlight washers started to leak out the bottom of the bumper- I opened the arch liner hatch and found one of the pipes was not connected. I re attached this- no more leak- but th washer dont pop up- the motor can be heard but no pop up!
Help!?
Z4 2.2 sterling grey,Msport seats,retrofit cupholders,cruise,footwell lights,sound gen and mfsw,18"ellipsoids,xenons+light washers,ZHPknob,folding mirrors,3"stubby,update wheel caps,gateway300 ipod, wind deflector to keep the wife happy!

User avatar
cj10jeeper
Lifer
Lifer
Posts: 17838
Joined: Fri Jun 22, 2007 11:50 am
Location: Lichfield, England

Re: headlight washers not working

Post by cj10jeeper » Tue Sep 15, 2009 11:22 pm

I've got to ask....Is there water in the reservoir?

OK - a bit more sensible - do you realise they only activate once every so many cycles of the washer (5 I think) and of course only once the headlights are on
Jaguar F-Type 3.0 Supercharged V6 S, Stratus Grey, LSD, Active Exhaust, CF wheels, Performance brakes, Sports seats and mods ongoing
Gone but not forgotten Z4 3.0i SE Roadster ///M front, Red ///M leather seats, Aero sills

User avatar
paddy wright
Lifer
Lifer
Posts: 6619
Joined: Sun Jan 06, 2008 1:00 pm
Location: south yorkshire

Re: headlight washers not working

Post by paddy wright » Tue Sep 15, 2009 11:28 pm

YES- I REFILLLED THE RESERVOIR- THE WASHERS MOTORS WIR AS THEY SHOULD FOR COMING UP BUT NO MOVEMENT! sorry for all the capital letters just realised caps lock was on
Z4 2.2 sterling grey,Msport seats,retrofit cupholders,cruise,footwell lights,sound gen and mfsw,18"ellipsoids,xenons+light washers,ZHPknob,folding mirrors,3"stubby,update wheel caps,gateway300 ipod, wind deflector to keep the wife happy!

User avatar
cj10jeeper
Lifer
Lifer
Posts: 17838
Joined: Fri Jun 22, 2007 11:50 am
Location: Lichfield, England

Re: headlight washers not working

Post by cj10jeeper » Wed Sep 16, 2009 8:40 am

There are 2 motors - 1 for the screen and 1 for the headlight washers. Are you sure that both are running as they are close together?
There are of course no motors in the jet themselves, they are just hydraulically operated and rise under pressure.

Beyond that you have to be looking for the pump impellor broken, blocked or kinked pipe, etc.
Jaguar F-Type 3.0 Supercharged V6 S, Stratus Grey, LSD, Active Exhaust, CF wheels, Performance brakes, Sports seats and mods ongoing
Gone but not forgotten Z4 3.0i SE Roadster ///M front, Red ///M leather seats, Aero sills

User avatar
EdButler
Senior Member
Senior Member
Posts: 1226
Joined: Mon Oct 13, 2008 9:41 am
Location: Sheffield

Re: headlight washers not working

Post by EdButler » Wed Sep 16, 2009 12:12 pm

Paddy, once when my washer reservoir ran out, it obviously air-locked the headlight washer lines. It took a few days (a few squirts a day) for my headlight washers to start working again. Just keep giving them a blast and the water should eventually get back through :)

User avatar
cj10jeeper
Lifer
Lifer
Posts: 17838
Joined: Fri Jun 22, 2007 11:50 am
Location: Lichfield, England

Re: headlight washers not working

Post by cj10jeeper » Wed Sep 16, 2009 12:46 pm

EdButler wrote:Paddy, once when my washer reservoir ran out, it obviously air-locked the headlight washer lines. It took a few days (a few squirts a day) for my headlight washers to start working again. Just keep giving them a blast and the water should eventually get back through :)
That's a good point Ed given that the hoses and then the jets themselves hold a high volume of washer fluid and they only operate intermittently every so many cycles and only while the headlights are on.
Jaguar F-Type 3.0 Supercharged V6 S, Stratus Grey, LSD, Active Exhaust, CF wheels, Performance brakes, Sports seats and mods ongoing
Gone but not forgotten Z4 3.0i SE Roadster ///M front, Red ///M leather seats, Aero sills

User avatar
paddy wright
Lifer
Lifer
Posts: 6619
Joined: Sun Jan 06, 2008 1:00 pm
Location: south yorkshire

Re: headlight washers not working

Post by paddy wright » Wed Sep 16, 2009 5:58 pm

ill keep trying - have used two reservoirs worth now and still no rise!
Z4 2.2 sterling grey,Msport seats,retrofit cupholders,cruise,footwell lights,sound gen and mfsw,18"ellipsoids,xenons+light washers,ZHPknob,folding mirrors,3"stubby,update wheel caps,gateway300 ipod, wind deflector to keep the wife happy!

User avatar
cj10jeeper
Lifer
Lifer
Posts: 17838
Joined: Fri Jun 22, 2007 11:50 am
Location: Lichfield, England

Re: headlight washers not working

Post by cj10jeeper » Wed Sep 16, 2009 6:11 pm

paddy wright wrote:ill keep trying - have used two reservoirs worth now and still no rise!
Disconnect the screen pump so you know only water is going to the headlight washers. If the level does not go down then you have pump or hose problems
Jaguar F-Type 3.0 Supercharged V6 S, Stratus Grey, LSD, Active Exhaust, CF wheels, Performance brakes, Sports seats and mods ongoing
Gone but not forgotten Z4 3.0i SE Roadster ///M front, Red ///M leather seats, Aero sills

User avatar
paddy wright
Lifer
Lifer
Posts: 6619
Joined: Sun Jan 06, 2008 1:00 pm
Location: south yorkshire

Re: headlight washers not working

Post by paddy wright » Wed Sep 16, 2009 6:16 pm

where is the screen pump located
Z4 2.2 sterling grey,Msport seats,retrofit cupholders,cruise,footwell lights,sound gen and mfsw,18"ellipsoids,xenons+light washers,ZHPknob,folding mirrors,3"stubby,update wheel caps,gateway300 ipod, wind deflector to keep the wife happy!

User avatar
cj10jeeper
Lifer
Lifer
Posts: 17838
Joined: Fri Jun 22, 2007 11:50 am
Location: Lichfield, England

Re: headlight washers not working

Post by cj10jeeper » Wed Sep 16, 2009 7:58 pm

Side of the reservoir tank
Jaguar F-Type 3.0 Supercharged V6 S, Stratus Grey, LSD, Active Exhaust, CF wheels, Performance brakes, Sports seats and mods ongoing
Gone but not forgotten Z4 3.0i SE Roadster ///M front, Red ///M leather seats, Aero sills

User avatar
paddy wright
Lifer
Lifer
Posts: 6619
Joined: Sun Jan 06, 2008 1:00 pm
Location: south yorkshire

Re: headlight washers not working

Post by paddy wright » Thu Sep 17, 2009 6:11 pm

cheers ed and cj- disconnected the window washer motor, the headlight one out to clean- fair few basts to clear the airlock adn away we go- back and working fine!!!!! :D
Z4 2.2 sterling grey,Msport seats,retrofit cupholders,cruise,footwell lights,sound gen and mfsw,18"ellipsoids,xenons+light washers,ZHPknob,folding mirrors,3"stubby,update wheel caps,gateway300 ipod, wind deflector to keep the wife happy!

User avatar
pvr
Legend
Legend
Posts: 22498
Joined: Fri Jun 15, 2007 12:27 pm
Location: South East UK

Re: headlight washers not working

Post by pvr » Thu Sep 17, 2009 6:46 pm

Your next problem will be the disappearing washer covers :D
911-50 Black - unique spec
X5M - 575 hp of fun in a V8
Abarth 595 Comp.
Golf Clipper - collectors item
Jeep
Z4M Silver Grey - non flimper spec (gone to Bing)

User avatar
EdButler
Senior Member
Senior Member
Posts: 1226
Joined: Mon Oct 13, 2008 9:41 am
Location: Sheffield

Re: headlight washers not working

Post by EdButler » Thu Sep 17, 2009 8:31 pm

Just dont run out now :p Or it wont work for agggges again!! :P

User avatar
Greeno
Member
Member
Posts: 650
Joined: Wed May 13, 2009 9:15 pm
Location: St ives, Cambs.

Re: headlight washers not working

Post by Greeno » Thu Sep 17, 2009 11:50 pm

Looks like i might have this fun and games to play with too as one of mine started to leak but i hadnt gotten round to investigate it yet.

Good to know you can see some of the workings taking off the arch liner hatch. i was thinking it was going to end up being a bumper off job.

Fingers crossed it will not....................
"Rules are for the guidance of the wise and the obedience of fools"

User avatar
a11y
Lifer
Lifer
Posts: 4851
Joined: Tue Dec 09, 2008 11:51 am
Location: Central Scotland
Contact:

Re: headlight washers not working

Post by a11y » Fri Sep 18, 2009 8:47 am

pvr wrote:Your next problem will be the disappearing washer covers :D
Since I don't have xenons I decided to disconnect my headlamp washers to avoid the disappearing cover issue :D

(AFAIK the washers are only necessary for xenons, not regular lamps, but I found them effing useless anyway)
::::: e90 330i M Sport :::::

Post Reply