2007 Z4 roadster 3.0si soft top stop working automatically

Discuss problems you have had or are having with your Z4
Post Reply
Richardlj27
Newbie
Newbie
Posts: 2
Joined: Sat Feb 09, 2019 2:13 am

2007 Z4 roadster 3.0si soft top stop working automatically

Post by Richardlj27 » Sat Feb 09, 2019 2:25 am

I installed a new stereo,now red light flashes on the top control button and top will go up and down manually but will not operate automatically and it was working fine a week ago

User avatar
road warrior
Senior Member
Senior Member
Posts: 1577
Joined: Wed May 23, 2018 2:12 pm
Location: Burton On trent

2007 Z4 roadster 3.0si soft top stop working automatically

Post by road warrior » Sat Feb 09, 2019 10:31 am

Upset your gaptec?
If you ever think I'm off my rocker.. Just put me back in it and walk away... It's the kindest thing
My wife says I never listen - or something like that.
Mean Steve 3.0 se. Noisy with bits
post whore = cheap, easily available and up for most things.

User avatar
ph001
Senior Member
Senior Member
Posts: 2269
Joined: Mon Oct 31, 2016 5:53 pm
Location: N. Yorkshire.

2007 Z4 roadster 3.0si soft top stop working automatically

Post by ph001 » Sat Feb 09, 2019 5:16 pm

Been playing around in the boot? Sounds like the shelf is in the upper position or the microswitch on it is misaligned or busted.
2007 E85 Z4 3.0Si manual :driving:
19" CSL's | Eibach Springs | Aeroskirts | Z4M front bumper | Clear brake light | ZHP | RCH+| Stubby

2004 E46 M3 coupe manual.

Richardlj27
Newbie
Newbie
Posts: 2
Joined: Sat Feb 09, 2019 2:13 am

2007 Z4 roadster 3.0si soft top stop working automatically

Post by Richardlj27 » Sun Feb 17, 2019 1:56 am

After a trip to the dealership where I purchased my Z4 for a diagnosis to give me an idea where to start, they found during my stereo installation I'd pulled plug out of control module under carpet

Post Reply