Steering knock/clunk at low speed/stationary

Discuss problems you have had or are having with your Z4
Post Reply
z4all
Member
Member
Posts: 691
Joined: Thu Dec 10, 2015 1:21 pm

Steering knock/clunk at low speed/stationary

Post by z4all » Sat Jan 12, 2019 8:34 am

Been happening for a month or so now. Video below. Any ideas lads?

http://sendvid.com/w5yipc8p

User avatar
1000rr
Member
Member
Posts: 586
Joined: Thu Oct 13, 2016 10:53 pm

Steering knock/clunk at low speed/stationary

Post by 1000rr » Sat Jan 12, 2019 10:17 am

Broken front spring?
Sterling 3.0, Red int, Aeros.

z4all
Member
Member
Posts: 691
Joined: Thu Dec 10, 2015 1:21 pm

Steering knock/clunk at low speed/stationary

Post by z4all » Sat Jan 12, 2019 3:02 pm

1000rr wrote:
Sat Jan 12, 2019 10:17 am
Broken front spring?
Hmmm. It doesn’t make any sort of sound when I go over a hump...wouldn’t it if it was a front spring?

User avatar
1000rr
Member
Member
Posts: 586
Joined: Thu Oct 13, 2016 10:53 pm

Steering knock/clunk at low speed/stationary

Post by 1000rr » Sat Jan 12, 2019 3:52 pm

Nope, mine did it exactly like yours.
Sterling 3.0, Red int, Aeros.

User avatar
Ewazix
Lifer
Lifer
Posts: 3945
Joined: Sun May 02, 2010 5:30 pm
Location: Somerset

Steering knock/clunk at low speed/stationary

Post by Ewazix » Sat Jan 12, 2019 3:54 pm

Possibly the UJ's in the steering shaft sticking (mine were) or top slip ring under the steering wheel which is a known cause of weird noises from clunk/clicking to a fog horn groan.

Previous topic viewtopic.php?f=3&t=34744

Let us know how it goes :thumbsup:
2003 2.5 SE, low miles, Sterling Grey, 108's & Eagles, no stubby here! Unmolested.
2018 Cooper S Countryman
Fiesta Ecoboost

z4all
Member
Member
Posts: 691
Joined: Thu Dec 10, 2015 1:21 pm

Steering knock/clunk at low speed/stationary

Post by z4all » Sat Jan 19, 2019 7:18 pm

Ok so springs are ok. The guy said the track rod and ends needed changing tho (even tho I didn’t rlly feel any issues with the handling). Got them done. The sound is still there ...

He checked again. He says it’s the steering rack.

Post Reply