Calling all INPA experts!

Discuss problems you have had or are having with your Z4
Post Reply
greg81
Member
Member
Posts: 854
Joined: Thu Mar 02, 2017 6:33 pm

Calling all INPA experts!

Post by greg81 » Tue Apr 24, 2018 7:28 pm

My steering is off by 15 degrees but I can't send to did where in INPA I can reset it. All videos I watch for slightly different BMW models have different options I don't have in my UI.

Can anyone point me in the direction of where I can do that in INPA?

Thanks in advance!
Last edited by greg81 on Thu Apr 26, 2018 8:48 pm, edited 1 time in total.

Scooba_Steve
Lifer
Lifer
Posts: 4563
Joined: Wed Feb 19, 2014 3:01 pm
Location: NW London

INPA reset steering angle sensor

Post by Scooba_Steve » Tue Apr 24, 2018 8:58 pm

You should be able to do it by going from lock to lock - I think.
3.0si Sport: F10 Illuminated ZHP, Retrofit Cruise, OE Stubby, Gaptech RCH+, Kenwood BT73DAB + Handsfree, HIDs, LED Sidelights, OE LED Number Plate Lights, Custom LED strip bootlight.

greg81
Member
Member
Posts: 854
Joined: Thu Mar 02, 2017 6:33 pm

INPA reset steering angle sensor

Post by greg81 » Thu Apr 26, 2018 11:01 am

Scooba_Steve wrote:
Tue Apr 24, 2018 8:58 pm
You should be able to do it by going from lock to lock - I think.
Thanks, but that didn't work for me unfortunately.

Having looked into this a little further I think I may have problems with my version/install of INPA. Every video I watch or tutorial I read they have options for resetting or for developers, but my options are always empty.

Could I potentially have a diagnostic only version of INPA? or can I install it with different settings to have compensations/dev mode enabled?

Thanks in advance

User avatar
ph001
Senior Member
Senior Member
Posts: 1487
Joined: Mon Oct 31, 2016 5:53 pm
Location: N. Yorkshire.

INPA reset steering angle sensor

Post by ph001 » Thu Apr 26, 2018 12:37 pm

I'm fairly sure it will be down to a communication problem with some of the car's modules. INPA can usually always connect OK to the main ECU but struggles with some of the ancillary ECUs if the settings / lead aren't quite right.

I'm struggling with the same issue with INPA not talking to certain modules at the moment tbh so not sure what the solution is. If I suss it out I will be sure to let you know. I would possibly change the thread title to something like "Any INPA experts on here?" as I know there are a few members who have a lot of experience with INPA. Might draw them in.
2007 E85 Z4 3.0Si manual :driving:
19" CSL's | Eibach Springs | Aeroskirts | Z4M front bumper | Clear brake light | ZHP | RCH+| Stubby

2004 E46 M3 coupe manual.

greg81
Member
Member
Posts: 854
Joined: Thu Mar 02, 2017 6:33 pm

INPA reset steering angle sensor

Post by greg81 » Thu Apr 26, 2018 8:48 pm

Cheers for that. It seems to read my DSC no problem at all, but just missing all the good options! I also get a version mismatch error which I'm sure isn't helping.

Thread title updated!

greg81
Member
Member
Posts: 854
Joined: Thu Mar 02, 2017 6:33 pm

Calling all INPA experts!

Post by greg81 » Thu Apr 26, 2018 8:58 pm

Seems I'm using V5.0.6

greg81
Member
Member
Posts: 854
Joined: Thu Mar 02, 2017 6:33 pm

Calling all INPA experts!

Post by greg81 » Fri Jul 06, 2018 6:11 pm

I managed to resolve my issues with a different install of INPA, which had developer options. I recallibrated my steering angle sensor and all my problems have gone away

User avatar
ph001
Senior Member
Senior Member
Posts: 1487
Joined: Mon Oct 31, 2016 5:53 pm
Location: N. Yorkshire.

Calling all INPA experts!

Post by ph001 » Sat Jul 07, 2018 11:29 pm

Thanks for updating :thumbsup:
2007 E85 Z4 3.0Si manual :driving:
19" CSL's | Eibach Springs | Aeroskirts | Z4M front bumper | Clear brake light | ZHP | RCH+| Stubby

2004 E46 M3 coupe manual.

greg81
Member
Member
Posts: 854
Joined: Thu Mar 02, 2017 6:33 pm

Calling all INPA experts!

Post by greg81 » Sat Jul 07, 2018 11:42 pm

For info the install I used was "mike's easy BMW tools"

The version that came with bcables was a complete pain in the ass. Mike's tools installed with one click.

greg81
Member
Member
Posts: 854
Joined: Thu Mar 02, 2017 6:33 pm

Calling all INPA experts!

Post by greg81 » Sat Jul 07, 2018 11:44 pm

Also worth mentioning that it was a breeze on windows 10. The old windows 7 laptop I tried was a troublesome.

Who knows if it was the windows version or the install package but this combo worked a dream for me

Post Reply