GPS signal

Discuss problems you have had or are having with your Z4
Post Reply
rays545i
Newbie
Newbie
Posts: 34
Joined: Thu Apr 06, 2017 2:34 pm
Location: London

GPS signal

Post by rays545i » Sat Jan 09, 2021 2:41 pm

Hi
this is a real head scratcher

I have a funny ( not so funny now ) my gps signal comes and goes but not as a move it’s engine on and off related
Removed my cheap Bluetooth module from rear of unit thought it might have something to do with that
Started car after on the drive within 1 min full sat lock
Went for a drive 2 hours later no dots at all for the drive pull over in a car park ignition off wait 30 sec ish turn on gps all good

I have changed gps antenna next to visor 3 weeks ago and just changed the head unit yesterday

I am at a complete loss
Any ideas ?

Many thanks
Ray

User avatar
mac27040
Lifer
Lifer
Posts: 3337
Joined: Wed Oct 26, 2011 5:17 pm
Location: Shepshed

GPS signal

Post by mac27040 » Thu Jan 14, 2021 12:33 pm

do you have factory sat nav or after market? the factory GPS is common fault that cable gets a crack in wire and works on and off. best to replace gps module
3.0i SMG Supercharged,19" CSL, AvinUSA android 10.25” screen,DSP,M6 gearknob,Coilovers,Aero F-bumper,M r-bumper,Aero skirts,Facelift front & rear lights,M sports seats,Carbon Steering wheel,Intravee,Rervese cam,Hydrographics

rays545i
Newbie
Newbie
Posts: 34
Joined: Thu Apr 06, 2017 2:34 pm
Location: London

GPS signal

Post by rays545i » Thu Jan 14, 2021 7:23 pm

Hi mate
I have replaced the antenna above windscreen and a new head unit
Still doing it
Only thing left to change is gps dvd unit behind seats
Cheers

Post Reply