Who hasn’t had a roof issue?

Specific discussion about the E89 2009 Z4 (sDrive35is, sDrive35i, sDrive30i, sDrive23i)
javis20
Member
Member
Posts: 221
Joined: Sun Aug 05, 2018 12:14 pm

Who hasn’t had a roof issue?

Post by javis20 » Mon Jun 29, 2020 11:42 am

No problems during my 2 years of ownership. And previous owners maintenance and repair record do list any roof problems, 2011 3.0i

Busterboo
Senior Member
Senior Member
Posts: 1996
Joined: Sun Nov 20, 2016 2:49 am

Who hasn’t had a roof issue?

Post by Busterboo » Mon Jun 29, 2020 11:50 am

47,000+ miles in my 35iS, many with the roof down, and no problems.
Vidi, vici, veni

ihadablackdog
Member
Member
Posts: 775
Joined: Thu Mar 08, 2018 9:56 pm

Who hasn’t had a roof issue?

Post by ihadablackdog » Mon Jun 29, 2020 12:23 pm

Do they do anything in the service to do with the roof?
2011 E89 sDrive20i

User avatar
scootr
Senior Member
Senior Member
Posts: 1194
Joined: Mon Sep 16, 2019 11:27 am
Location: Temecula

Who hasn’t had a roof issue?

Post by scootr » Mon Jun 29, 2020 12:54 pm

ihadablackdog wrote:
Mon Jun 29, 2020 12:23 pm
Do they do anything in the service to do with the roof?
I think you should change the relays at some point.
E89 3.0L 6 spd manual
Image
Michelin NRF Pilot 4s
Bilstein struts & shocks
Luxon tower brace

User avatar
scootr
Senior Member
Senior Member
Posts: 1194
Joined: Mon Sep 16, 2019 11:27 am
Location: Temecula

Who hasn’t had a roof issue?

Post by scootr » Mon Jun 29, 2020 12:55 pm

scootr wrote:
Mon Jun 29, 2020 12:54 pm
ihadablackdog wrote:
Mon Jun 29, 2020 12:23 pm
Do they do anything in the service to do with the roof?
I think you should change the relays at some point. I changed my 10 yr old relays and the old ones looked frightfully pitted and worn.
E89 3.0L 6 spd manual
Image
Michelin NRF Pilot 4s
Bilstein struts & shocks
Luxon tower brace

mcbutler
Senior Member
Senior Member
Posts: 1404
Joined: Fri May 26, 2017 3:40 pm
Location: Plymouth

Who hasn’t had a roof issue?

Post by mcbutler » Mon Jun 29, 2020 1:32 pm

2009 23i two years no issues
2009 35i 14 months no issues
Mark
Plymouth
E89
35i
Carmine Red
Black leather

User avatar
maxman
Senior Member
Senior Member
Posts: 2428
Joined: Mon Jun 07, 2010 11:34 pm
Location: Wrexham

Who hasn’t had a roof issue?

Post by maxman » Mon Jun 29, 2020 2:48 pm

2009 ,23i, 57k Hall sensor replaced.New battery and Salmon relays replaced last year.
E89 2.3 Sdrive Sapphire Black.

JamiesZ4
Member
Member
Posts: 67
Joined: Mon Apr 02, 2018 10:46 am
Location: Bexley, Kent

Who hasn’t had a roof issue?

Post by JamiesZ4 » Tue Jun 30, 2020 6:10 pm

Ha ha! On my 2010 50,000 miler, I have had:

Roof hydraulics replaced
2 sections of wiring replaced
3 hall sensors
2 salmon sensors

And I’ve just noticed the two side trim inserts that close to cover the wiring situated above the seat headrests have now seized, neither affect the roof going up and down but will claim on the warranty shortly...

My car is the proverbial lemon though and the extended warranty company almost dread a call from Stephen James Ruxley in relation to a certain black BMW Z4 :D £12K of work done so far on warranty and rising :cry:
Current - E89 Z4 SDrive 3.0i - last of the normally aspirated six cylinders
Gone - E85 Z4 2.2 SE

Silverstar
Senior Member
Senior Member
Posts: 1116
Joined: Fri Jun 21, 2019 10:06 am
Location: Costa Del Sol

Who hasn’t had a roof issue?

Post by Silverstar » Tue Jun 30, 2020 6:38 pm

JamiesZ4 wrote:
Tue Jun 30, 2020 6:10 pm
My car is the proverbial lemon though and the extended warranty company almost dread a call from Stephen James Ruxley in relation to a certain black BMW Z4 £12K of work done so far on warra
You weren't kidding, that is a lemon!
2009 sdrive30i auto Sapphire Black / Coral Red

Online
User avatar
mkinternet
Newbie
Newbie
Posts: 48
Joined: Mon Jun 11, 2018 8:38 am
Location: Bedford

Who hasn’t had a roof issue?

Post by mkinternet » Tue Jun 30, 2020 11:09 pm

2010 - 84,000 miles and no issues, well apart from replacing the buttons as the icons had bubbled up. Last week replaced the relays just because as far as I could tell they never had been replaced. More a preventative measure 😁

Maybach_man
Member
Member
Posts: 62
Joined: Wed Jul 18, 2018 9:03 pm
Location: South Buckinghamshire

Who hasn’t had a roof issue?

Post by Maybach_man » Wed Jul 01, 2020 7:20 am

2016 car 13000 miles Out of warranty but still has the service contract for another year... no roof issues...but will be picking up 2 salmon relays when it goes in for a service next week, just to be safe.....

Ouroux71
Member
Member
Posts: 143
Joined: Thu Feb 13, 2020 10:35 am
Location: Ouroux sur Saone, FRANCE

Who hasn’t had a roof issue?

Post by Ouroux71 » Wed Jul 01, 2020 10:16 am

My 2009 45000 mile vehicle has had no issues except in relation to me fitting a remote roof control unit. This led me to believe it was the roof (but it wasn't). I contacted the previous owner who said he had never had any roof issues.
I use the roof about 2-3 times per week - car is always garaged. Using the roof less at the moment due to extreme heat we are suffering.
I did change the salmon relays recently and they hadn't been changed since new. I also changed the main battery as any older battery will give electronic issues.
Z4 2.3S Drive 2009, 40,000 miles: 6 speed, Sapphire black. PDC, Ski Hatch, Extended Lighting, headlamp wash, interior storage pack, Canberra Beige leather, rain sensor/auto lights, auto dipping rear mirror, seat heating, wind deflector, 19'' wheels.

User avatar
Beeacon
Member
Member
Posts: 247
Joined: Sun Jun 03, 2018 4:07 pm
Location: Manchester, UK

Who hasn’t had a roof issue?

Post by Beeacon » Wed Jul 01, 2020 2:26 pm

Ouroux71 wrote:
Wed Jul 01, 2020 10:16 am
My 2009 45000 mile vehicle has had no issues except in relation to me fitting a remote roof control unit. This led me to believe it was the roof (but it wasn't). I contacted the previous owner who said he had never had any roof issues.
I use the roof about 2-3 times per week - car is always garaged. Using the roof less at the moment due to extreme heat we are suffering.
I did change the salmon relays recently and they hadn't been changed since new. I also changed the main battery as any older battery will give electronic issues.
I have a SmartTop unit that was being a bit funny when I got it. There is updated firmware on their website which I downloaded, installed via the USB (leave the usb in place so you can access it in the future if you need to) and voila, intermittent problems resolved. Might be as simple as that.
Current: 2009 BMW Z4 35i sDrive DCT
Past: 1997 BMW Z3 2.8 wide boy

Dru2000D
Newbie
Newbie
Posts: 44
Joined: Sun Mar 17, 2019 9:20 pm

Who hasn’t had a roof issue?

Post by Dru2000D » Wed Jul 01, 2020 8:30 pm

I had an issue with the roof malfunctioning and the windows wouldn't work so with all the heavy rain, had tarp over the car. I bought a roof module 2nd hand on eBay and got it installed, the windows now work but roof doesn't. Not sure if it's because it came from the 3.0 which might be coded differently perhaps?

I need to waterproof my boot!!! That's the issue unfortunately

User avatar
bob20124
Newbie
Newbie
Posts: 8
Joined: Fri Jan 24, 2014 10:28 pm

Who hasn’t had a roof issue?

Post by bob20124 » Wed Jul 01, 2020 9:07 pm

2011 picked up as a CPO in 2013. 7 years and 67,000 mi. problem free. I just changed relays for peace of mind.
2011 35i BMS low and high side OCC, Custom tune by BQ Tuning, CDV delete, ER Charge Pipe w/Tial BOV, ER Comp. FMIC, K&N drop in,40W LED Halo, LCI side markers, M-Factory LSD, Stubby, Windrestrictor

Post Reply