Not joined yet? Register for free and enjoy features such as alerts, private messaging and viewing latest posts and topics.

How accurate is the idrive info?

Specific discussion about the E89 2009 Z4 (sDrive35is, sDrive35i, sDrive30i, sDrive23i)
flybobbie
Senior Member
Senior Member
Posts: 2691
Joined: Sat May 25, 2013 8:27 pm

How accurate is the idrive info?

Post by flybobbie » Tue Sep 14, 2021 12:48 pm

I'm on third set rear and one set front.
Keep in mind how often the ebrake makes them rub on disc.
Having had front discs off recently very impressed with how little rust or corrosion on the Mtec discs.
What there was just brushed off with clean steel underneath.

Silverstar
Senior Member
Senior Member
Posts: 1836
Joined: Fri Jun 21, 2019 10:06 am
Location: Costa Del Sol

How accurate is the idrive info?

Post by Silverstar » Tue Sep 14, 2021 9:13 pm

ori wrote: Mon Sep 13, 2021 10:49 pm
Silverstar wrote: Mon Sep 13, 2021 9:57 pm
ori wrote: Mon Sep 13, 2021 2:57 pm The strange thing for me was that the rears always wore out quicker than the fronts on my last 2 zeds. I think that has to do with the stability control.
On most cars the front pads wear out way quicker than the backs but on the Z4 I think it is the other way around. Looking at the history that came with my car the rear pads have been changed twice and fronts once.
When I spoke to my bmw dealership, it’s quite common on BMWs for rears to wear out quicker. Something about the setup. Who knows?
This E89 Z4 is my first BMW I have encountered this on, all my other BMWs it was the other way (normal way) round. Maybe something to do with the way the newer models are setup with the DSC traction etc.
2009 sdrive30i auto Sapphire Black / Coral Red

Jasonn
Member
Member
Posts: 291
Joined: Wed Nov 13, 2019 10:38 pm

How accurate is the idrive info?

Post by Jasonn » Wed Sep 15, 2021 6:25 pm

Silverstar wrote: Fri Sep 10, 2021 4:01 pm So I took my car into the mechanics today who found the aftermarket sensors cable fitted before had snapped off hence why I was getting the bong! They replaced it with a brand new BMW original cable and reset the computer but it still only shows 10,000 kms for the front pads! Could it be his scan tool? My mechanic says the only option in his computer is to check how much wear is left or to reset it and when he resets it, the car only shows 10,000 kms!
Mine went on the ramps today and cable for the front sensor had snapped about 4" from the sensor, looks like it had stretched. The mechanic thinks it may have caught on something in the road which caused the damage.

Reset and it now shows 6000 miles

Post Reply