Page 1 of 1

Convertible top doesn't lift off windshield header without little push

Posted: Thu Mar 14, 2019 1:59 am
by Z4-04
With my 2004, Z4, 3.0i, 51,000 miles when I push the top down button the top doesn't lift off the windshield header unless I give it a little push. After that the top goes down at normal speed and it returns back up at normal speed. This situation just started last week. I have had the car for a year and had a new top pump system installed a year ago.

Is there an issue with the unlocking mechanism?

Convertible top doesn't lift off windshield header without little push

Posted: Thu Mar 14, 2019 2:21 am
by Bluesguy
I just got mine about 3 weeks ago and had a problem with one of the sensors which tell if the trunk tray is down else the top won't retract. It start after a day or two. They installed a new module and had it reprogam but then discovered the new carpet that was installed in the trunk was interfering with the sensor. They fixed that.

Now mine is doing the same thing. I am hoping it will work it's way out of it but think it needs to have the module programing fixed.

Convertible top doesn't lift off windshield header without little push

Posted: Thu Mar 14, 2019 3:18 am
by Z4-04
I will check my trunk sensor in the morning. I also read somewhere that the hooking system at the header sometimes needs to be lubricated. I will also do that in the morning.

Convertible top doesn't lift off windshield header without little push

Posted: Thu Mar 14, 2019 5:35 am
by tomrdy
if you can hear the motor winding but the roof just looks "stuck", its most likely just the latch is a bit sticky.

Mine did it randomly once so I just sprayed some silicone lube on the surface. Has been fine since.

Convertible top doesn't lift off windshield header without little push

Posted: Thu Mar 14, 2019 10:30 pm
by Z4-04
Tomrdy, your suggestion worked. I lubricated the latch, two hooks and mechanism's and the top is now lifting off the header on its own.
Thanks

Convertible top doesn't lift off windshield header without little push

Posted: Fri Mar 15, 2019 1:12 am
by tomrdy
Z4-04 wrote:
Thu Mar 14, 2019 10:30 pm
Tomrdy, your suggestion worked. I lubricated the latch, two hooks and mechanism's and the top is now lifting off the header on its own.
Thanks
No worries glad to hear it :)