Loose xenon

Discuss problems you have had or are having with your Z4
Post Reply
BradleyB
Member
Member
Posts: 345
Joined: Wed Apr 09, 2014 10:21 am
Location: Surrey

Loose xenon  

Post by BradleyB » Sat Nov 11, 2017 12:36 pm

Hi guys,

I had an issue a little while ago where one of my xenon bulbs would appear to rattle over any tiny bump in the road. Quite irritating as the beam would be all over the place at times.

Anyway this was fixed when I took the M to the stealers for its MOT. They didn’t mention there was an issue or that they fixed it, however it was fixed!

Last night I was fitting some new AE bulbs and I must have touched the xenon, so it’s now rattling again. I’ve had another look and I can move the unit up and down but it is still fixed in place.

Has anyone had this problem before and if so, is this something I can fix?

Thanks! :D
'56 ///MR

User avatar
Ducklakeview
Lifer
Lifer
Posts: 5015
Joined: Tue Mar 22, 2016 4:08 pm
Location: Merseyside

Loose xenon

Post by Ducklakeview » Sat Nov 11, 2017 12:55 pm

IS the "whole" reflector assembly moving, or just the igniter on the back of the xenon (square metal box) if the former, the fixing studs may be loose, the latter, then the igniter probably not clipped in properly, it pushes onto the back of the "bulb" and turns clockwise to lock, the top should be level if it's fully home.

Mike

BradleyB
Member
Member
Posts: 345
Joined: Wed Apr 09, 2014 10:21 am
Location: Surrey

Loose xenon

Post by BradleyB » Sat Nov 11, 2017 5:09 pm

Ducklakeview wrote:
Sat Nov 11, 2017 12:55 pm
IS the "whole" reflector assembly moving, or just the igniter on the back of the xenon (square metal box) if the former, the fixing studs may be loose, the latter, then the igniter probably not clipped in properly, it pushes onto the back of the "bulb" and turns clockwise to lock, the top should be level if it's fully home.

Mike
It’s the whole assembly that’s wobbling. Do you have any idea if I’ll be able to get to the fixing studs from the wheel arch (wheel on)?
'56 ///MR

MACK
Senior Member
Senior Member
Posts: 2081
Joined: Mon Jun 15, 2015 11:38 am
Location: Manchester

Loose xenon

Post by MACK » Sat Nov 11, 2017 9:07 pm

BradleyB wrote:
Sat Nov 11, 2017 5:09 pm
Ducklakeview wrote:
Sat Nov 11, 2017 12:55 pm
IS the "whole" reflector assembly moving, or just the igniter on the back of the xenon (square metal box) if the former, the fixing studs may be loose, the latter, then the igniter probably not clipped in properly, it pushes onto the back of the "bulb" and turns clockwise to lock, the top should be level if it's fully home.

Mike
It’s the whole assembly that’s wobbling. Do you have any idea if I’ll be able to get to the fixing studs from the wheel arch (wheel on)?
Iirc you should be able to get in there with the wheel turned in and the covers off. If it's just a case of tightening up the fixing you should be fine to do it in situ. Anything more fiddly than that and it might be easier to remove from the car and have it flat on a bench.
05 3.0i SE in Titanium.
Mods inc - Facelift Xenons, M Sport Wheel & Leather Elec/Heated Seats, 15 & 20mm Spacers & M Tyre Sizes. 3M Carbon Fibre Trim, 4 Spot Clear Rear Lights, Gaptech+, Cruise, MM Tips, ZHP, Stubby.

BradleyB
Member
Member
Posts: 345
Joined: Wed Apr 09, 2014 10:21 am
Location: Surrey

Loose xenon

Post by BradleyB » Tue Nov 21, 2017 6:43 pm

Thanks for your help guys. I took the headlight off the car in the end to take a better look. Turns out it was quite simple anyway. The wobbly light assembly just needed to be push back onto the housing. You’ll be welcomed with a reassuring clip if it’s done correctly!
'56 ///MR

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests