Heater problems Z4 E85

Discuss problems you have had or are having with your Z4
Post Reply
GSD
Newbie
Newbie
Posts: 1
Joined: Sat Dec 02, 2017 12:31 pm

Heater problems Z4 E85

Post by GSD » Sat Dec 02, 2017 12:43 pm

Hi all, have a problem with heat only blowing hot outa drivers side, I'm ok but Mrs not so keen :(

User avatar
Grumpyowl
Lifer
Lifer
Posts: 3175
Joined: Mon Aug 12, 2013 8:00 pm
Location: North Derbyshire

Heater problems Z4 E85

Post by Grumpyowl » Sat Dec 02, 2017 9:08 pm

I have the same problem, however my car is a summer garage queen and I don't need the heater.
I would like it to heat both sides though as it's the only thing not working properly on my car.
Interested to hear your replies from anyone in the know.

R80CLE
Newbie
Newbie
Posts: 47
Joined: Thu Jun 30, 2016 7:25 am

Heater problems Z4 E85

Post by R80CLE » Sat Dec 02, 2017 10:11 pm

Mine also does this :lol:

I will await responses.

User avatar
Vegas
Newbie
Newbie
Posts: 30
Joined: Tue Jan 03, 2017 5:15 pm
Location: Shaw, Manchester

Heater problems Z4 E85

Post by Vegas » Mon Dec 04, 2017 7:48 pm

I too have the same problem. :lol:
3.0 Auto, Sterling Grey, Hardtop, Professional Nav, DSP, Digital TV, Bluetooth, Cruise Control, Xenons, MFSW, Cupholders, Auto Lights, Auto Wipers, Folding Mirrors, Memory seats, Wind deflector, PDC, 108's, LED sides and Fogs, Stubby, Intravee.

User avatar
Grumpyowl
Lifer
Lifer
Posts: 3175
Joined: Mon Aug 12, 2013 8:00 pm
Location: North Derbyshire

Heater problems Z4 E85

Post by Grumpyowl » Thu Dec 07, 2017 7:59 pm

A little bump for this.

This seems to be a problem for more than a few, wonder if it's a broken directional flap in the heater box ?

I seem to remember a post that I can't find, someone putting foam in the drivers side footwell vent to try to divert some warm air to the passenger side.
I wonder if it worked.

Online
User avatar
ph001
Member
Member
Posts: 621
Joined: Mon Oct 31, 2016 5:53 pm
Location: N. Yorkshire.

Heater problems Z4 E85

Post by ph001 » Thu Dec 07, 2017 9:16 pm

The air diversion flaps are motorised by a servo. They would be certainly worth checking but I bet access is a bitch :evil:
2007 E85 Z4 3.0Si manual :driving:
19" CSL's | Eibach Springs | Aeroskirts | Z4M front bumper | Clear brake light | ZHP | RCH+| Stubby

2004 E46 M3 coupe manual.

Athers
Newbie
Newbie
Posts: 1
Joined: Sat Sep 09, 2017 12:15 am

Heater problems Z4 E85

Post by Athers » Fri Dec 08, 2017 11:48 pm

What models are people having problems with please?

I have the same problem on my 2.0 2005.

There is still air coming out of the passenger side but it is cold....

I'm also certain that the heat I have on drivers side isnt what it should be...

On checking the feed pipes from radiator/block through the bulkhead they are screaming red hot....

I understand there may be a matrix which might be the source if the problem.

However there are multiple threads on heater issues but this is the only one with a consistent problem.

Any help greatly appreciated!!!

Athers

User avatar
Ducklakeview
Lifer
Lifer
Posts: 5014
Joined: Tue Mar 22, 2016 4:08 pm
Location: Merseyside

Heater problems Z4 E85

Post by Ducklakeview » Sat Dec 09, 2017 12:49 am

If you remove the glovebox, you can get to the actuator motors quite easily. If you have access to diagnostic kit, your can run them through their range of movement and also perform a baseline positional reset. They can, and do "lose track" of their positions..

Mike

User avatar
Grumpyowl
Lifer
Lifer
Posts: 3175
Joined: Mon Aug 12, 2013 8:00 pm
Location: North Derbyshire

Heater problems Z4 E85

Post by Grumpyowl » Sat Dec 09, 2017 9:06 am

Ducklakeview wrote:
Sat Dec 09, 2017 12:49 am
If you remove the glovebox, you can get to the actuator motors quite easily. If you have access to diagnostic kit, your can run them through their range of movement and also perform a baseline positional reset. They can, and do "lose track" of their positions..

Mike
As with Athers above mine blows cold passenger side and hot drivers side .

That's good info Mike, when I come to see you in the spring you can check it out for me.

I hope it doesn't upset anybody by saying the above :poke: :rofl:

cooknerkid
Newbie
Newbie
Posts: 3
Joined: Fri Jul 17, 2015 9:47 pm
Location: Northampton

Heater problems Z4 E85

Post by cooknerkid » Sun Dec 10, 2017 6:14 pm

I also have same on my z4 2.5 SE 2007. Wife complains feet cold. My ankle is burning !!!!

Post Reply

Who is online

Users browsing this forum: Google Adsense [Bot], kev m, Mlockman, timmy3k and 19 guests